Staredit Network > Forums > SC1 UMS Mapmaking Assistance > Topic: cant click single digit in scmdraft trigger
cant click single digit in scmdraft trigger
Jan 18 2009, 3:58 am
By: alexpnd  

Jan 18 2009, 3:58 am alexpnd Post #1



I receive a Richtext20 error is this the possible cause? In the trigger editor if I have a condition or action that i want to Edit and it has only a single digit in it (eg. Create 2 marines at location) I cant click the 2 , I have to create a whole new command. Its very frustrating. Has anybody else had this problem? I'm using the latest SCMDraft



None.

Jan 18 2009, 4:20 am badcop Post #2



Use the text trigger editor for now I guess, as i know nothing of this type of thing, but you can use the text trigger editor in the mean time if you must.



None.

Jan 18 2009, 4:25 am BlackWolf99 Post #3



it works just fine for me. Maybe ur not selecting it accurately enuf. took me some tries to highlight it and change it



None.

Jan 18 2009, 4:33 am Falkoner Post #4



It seems to me that this is an issue with your computer, not with SCM Draft.



None.

Jan 18 2009, 4:34 am Zone Post #5



rofl yea... try harder , get a better mouse , because my scmd2 works :)



None.

Jan 18 2009, 4:36 am poison_us Post #6

Back* from the grave

Wow, my computer is a WinME and it still runs scmdraft2 perfectly...Are you on Vista?




Jan 18 2009, 5:13 am alexpnd Post #7



The text editor doesnt work at all for me. I dont know what the problem is. Usually on editable properties the cursor changes to a hand. When it is one digit (eg. 1 in comparison to 10) it doesnt show this select tool, its as if its just part of other text. I'm going to try to replace my system richtext20.dll with the one in the starcraft folder.

edit: actually i forgot it wont let me because it says its being used even with all programs shut down. Anybody??? PLEASE!! :(



None.

Jan 18 2009, 5:17 am Roy Post #8

An artist's depiction of an Extended Unit Death

Well... I can't remember specifically, but after you download a few things, SCMD2 should work fine. I remember having this problem when I tried using SCMD2 on my laptop.

Try installing Microsoft .Net framework 1.1:

http://www.microsoft.com/downloads/details.aspx?FamilyID=262d25e3-f589-4842-8157-034d1e7cf3a3&displaylang=en

You don't need to replace any files.




Jan 18 2009, 5:21 am alexpnd Post #9



Thanks Roy but I solved it. I guess it didnt like the Riched20.dll that was packaged with scm so I replaced it with the one in my system32 folder and it works just fine! Thanks everyone for that finger pointing as well as the support :)

EDIT:
Oh on a side note. Who uses the text editor (as it works now) and do you find it faster/more efficient once you know all the commands?

Post has been edited 1 time(s), last time on Jan 18 2009, 5:34 am by NudeRaider. Reason: merged posts



None.

Jan 18 2009, 5:37 am NudeRaider Post #10

We can't explain the universe, just describe it; and we don't know whether our theories are true, we just know they're not wrong. >Harald Lesch

Text triggers are for mass trigger creation via external programs like trigger duplicators.
Creating text triggers manually is a pain in the ass.

It's also useful for bugfixing / changing many similar triggers (find and replace).
But when you use it don't forget to hit the compile checkmark before closing, or all your changes will be lost.




Jan 19 2009, 4:34 am Dungeon-Master Post #11



Yea i had the same problem with the digits and i had an error message at startup. I remember i fixed it when i deleted SCMD and downloaded it again. I thougt it was my computer going nutz, and i thougt it was an issue in early versions... Anyway, you fixed it and it is all that matters!



None.

Options
  Back to forum
Please log in to reply to this topic or to report it.
Members in this topic: None.
[06:30 am]
Ultraviolet -- :lol:
[03:35 am]
jjf28 -- easy not necessarily the word I'd use, but should be doable
[05:43 pm]
Zoan -- NudeRaider
NudeRaider shouted: Zoan yes you can.
oh, yeah you’re right. Then yeah if you use an ai script it should be easy to farm unfinished buildings in some unused area on the map and just move them around, right?
[2019-10-17. : 6:06 am]
NudeRaider -- KrayZee
KrayZee shouted: Voyager7456 Somehow I misread your shout. "Glad I can entertain you in Nude" as if you sent a racy photo, video or something.
nah, he just made a comment that had us laughing very hard.
[2019-10-17. : 6:02 am]
NudeRaider -- Zoan
Zoan shouted: sraw531 you can’t move buildings afaik
yes you can.
[2019-10-16. : 10:03 pm]
Dem0n -- no
[2019-10-16. : 8:26 pm]
GGmano -- Is here a forum only for temple siege?
[2019-10-16. : 4:20 pm]
KrayZee -- Voyager7456
Voyager7456 shouted: Glad I can entertain you Nude
Somehow I misread your shout. "Glad I can entertain you in Nude" as if you sent a racy photo, video or something.
[2019-10-16. : 2:26 pm]
martosss -- Moose
Moose shouted: martosss IIRC, the plan was to go 64-bit only eventually so they're interested in differences between the versions
well I might have found 1 bug for them to fix - some maps load on 32 bit, but not on 64 bit game version
[2019-10-16. : 2:19 pm]
Zoan -- sraw531
sraw531 shouted: I'm pretty sure you would move the building away at some point. When you do so, you can give it to someone else. I was thinking nexi because its possible you could encourage the computer to expand to a specific spot
you can’t move buildings afaik
Please log in to shout.


Members Online: Roy