Staredit Network > Forums > Modding Assistance > Topic: strange upgrade problem
strange upgrade problem
Mar 5 2016, 4:16 pm
By: SCRuler  

Mar 5 2016, 4:16 pm SCRuler Post #1



I have a really strange issue that recently came up.
For some reason, a lot of upgrades, even main game ones, have vanished from their places in game on the command card.
They're still there in firegraft, including the new ones im trying to implement.

Attachments:
ShitModBeta1.exe
Hits: 1 Size: 2057.08kb



None.

Mar 6 2016, 1:40 am Corbo Post #2

ALL PRAISE YOUR SUPREME LORD CORBO

Are you testing it in a very specific map that would somehow have all upgrades disabled for all players?

Sounds more like a map-specific issue. I'm testing the mod asap, though.


Yeah, seems to be fine for me. Also, your... whatever you did with the Magellan science vessel crashes. Like it either immediately crashes on game start or crashes when moved. Probably iscript calling to something it doesn't exist.

Post has been edited 3 time(s), last time on Apr 8 2016, 2:32 am by Roy.



fuck you all

Mar 6 2016, 6:15 pm SCRuler Post #3



Quote from Corbo
Are you testing it in a very specific map that would somehow have all upgrades disabled for all players?

Sounds more like a map-specific issue. I'm testing the mod asap, though.


Yeah, seems to be fine for me. Also, your... whatever you did with the Magellan science vessel crashes. Like it either immediately crashes on game start or crashes when moved. Probably iscript calling to something it doesn't exist.
It shouldn't be a map specific issue, all the upgrades were able to be researched, listed there. And I tested it on a melee map. The Ultralisk's upgrades weren't there, neither were the protoss energy upgrades.
yeah I know. I did that mess myself. I switched the Magellan to the ragnasaur so that I could make him into a renegade scivess, but it turned out to be a mess. I was hoping you could coach me on how to do that properly.

Also I need more help with the turrets thing.
It's more wonky than i figured it'd be. I need help with it.

Post has been edited 1 time(s), last time on Mar 6 2016, 6:26 pm by SCRuler.



None.

Mar 15 2016, 1:43 pm UndeadStar Post #4



Question: do you keep saving over and over again on the same .exe with Firegraft?

Don't know if it's related, but just now, I freaked out seeing during my tests that the icons to make buildings (the "normal buildings" and "advanced buildings" icon in the buttonset) for Terrans no longer appeared.
After many tests with changes on plugin, I tried creating a default config with Firegraft, then saving it over the .exe and surprise: still no terran buildings.

But everything was fixed miraculously when I deleted the .exe then created a new one (working with and without plugins).

I wonder what went wrong in my case, but something did, and maybe you have something like that.



None.

Mar 15 2016, 9:35 pm Voyager7456 Post #5

Responsible for my own happiness? I can't even be responsible for my own breakfast

Quote from UndeadStar
Question: do you keep saving over and over again on the same .exe with Firegraft?

Don't know if it's related, but just now, I freaked out seeing during my tests that the icons to make buildings (the "normal buildings" and "advanced buildings" icon in the buttonset) for Terrans no longer appeared.
After many tests with changes on plugin, I tried creating a default config with Firegraft, then saving it over the .exe and surprise: still no terran buildings.

But everything was fixed miraculously when I deleted the .exe then created a new one (working with and without plugins).

I wonder what went wrong in my case, but something did, and maybe you have something like that.

I've also seen this happen.



all i am is a contrary canary
but i'm crazy for you
i watched you cradling a tissue box
sneezing and sniffling, you were still a fox


Modding Resources: The Necromodicon [WIP] | Mod Night
My Projects: SCFC | ARAI | Excision [WIP] | SCFC2 [BETA] | Robots vs. Humans | Leviathan Wakes [BETA]


Mar 16 2016, 6:41 pm SCRuler Post #6



Quote from UndeadStar
Question: do you keep saving over and over again on the same .exe with Firegraft?

Don't know if it's related, but just now, I freaked out seeing during my tests that the icons to make buildings (the "normal buildings" and "advanced buildings" icon in the buttonset) for Terrans no longer appeared.
After many tests with changes on plugin, I tried creating a default config with Firegraft, then saving it over the .exe and surprise: still no terran buildings.

But everything was fixed miraculously when I deleted the .exe then created a new one (working with and without plugins).

I wonder what went wrong in my case, but something did, and maybe you have something like that.
I see, I'll have to do a refresh.



None.

Options
  Back to forum
Please log in to reply to this topic or to report it.
Members in this topic: None.
[06:36 pm]
Suicidal Insanity -- fortheovermind
fortheovermind shouted: my turn rate bar from the Create panel is no longer there. my games are created with the default 12 and i can no longer modify it, what could be causing this?
Known patch bug
[06:07 pm]
Ultraviolet -- lifebot This version appears to be older than the version I already have downloaded (1.5). Why is this one being posted?
[06:03 pm]
Ultraviolet -- Zoan
Zoan shouted: MTiger156 lifebot woah, that's awesome! I'm too lazy right now to check, but does it work with Remastered or 1.1.16 only?
I haven't used it in the latest version of remastered, but I assume it still works. It definitely did before. It's pretty neat. Super fast & easy way to create a save/load system
[05:02 pm]
fortheovermind -- my turn rate bar from the Create panel is no longer there. my games are created with the default 12 and i can no longer modify it, what could be causing this?
[04:50 pm]
Zoan -- MTiger156
MTiger156 shouted: Also, here's a link to its actual description http://www.staredit.net/topic/17696/
lifebot woah, that's awesome! I'm too lazy right now to check, but does it work with Remastered or 1.1.16 only?
[04:18 pm]
Dem0n -- o nvm you're talking about SCDB, not the map
[04:17 pm]
Dem0n -- wtf is a "software innovation" in BW LMAO
[04:16 pm]
Dem0n -- no
[02:45 pm]
MTiger156 -- Also, here's a link to its actual description http://www.staredit.net/topic/17696/
[02:33 pm]
MTiger156 -- One of the greatest software innovations in all of SCBW :P
Please log in to shout.


Members Online: Roy, atom379634, GGmano, 8z2b3z2c7xc5bn, MTiger156, zsnakezz