Staredit Network > Forums > General StarCraft > Topic: Forwarding Ports - Fixing Hosting, Lat, and UDP Issues
Forwarding Ports - Fixing Hosting, Lat, and UDP Issues
Oct 10 2015, 1:28 am
By: jjf28  

Dec 20 2015, 10:42 pm sigsaucy Post #21



tried just UDP forwarding, didn't work. Looking at my LAN settings it says

IPv4 Connectivity: Internet
IPv6 Connectivity: No Network Access




Dec 21 2015, 1:03 pm Moose Post #22



It might be worth checking if your modem has its own port controls.




Dec 21 2015, 2:25 pm ClansAreForGays Post #23



Quote from Mini Moose 2707
It might be worth checking if your modem has its own port controls.
This is what got it to work for me.




Dec 22 2015, 6:57 pm sigsaucy Post #24



I talked to my internet peoples and they said they dont block any ports, that the problem is on my side, he also said that the modem acted as a bridge so it wouldn't block anything

ROUTER: http://www.amazon.com/Medialink-Wireless-N-Broadband-Internal-Antenna/dp/B00A3YN0Z0

MODEM: westell e90-610030

So ive tried lots of stuff....

A)

I've connected my desktop straight to the modem, bypassing the router, even with this set up my 6112 port is closed

When trying to access the modem to check settings I'm unable to access it using any ip address. The only way I've been able to access it is by resetting the modem, once it's reset I can access it but the internet doesn't work. I have to do stuff like set the router to bridged, VCI/VIP = 0/35, and disable DHCP. After I do this I reset the modem and the internet works but I can't access the router.

When looking at the modem settings I didn't really see anything having to do with port forwarding so I'm not sure accessing it would help me anyways.



B)

While connected to my router, I look up my IPv4 Address, and set port forwarding 6112 for UDP/TCP/Both. I check and the port is still closed.




I've tried all this with windows firewall off but it still doesn't work. Getting pretty sad :(. I don't remember exactly but these problems may have started around the time I installed windows 10.

Is there any chance that there is a problem with my router and I should just get a new one? Any suggestions on which one?

My router also has a firewall setting, disabling it hasn't fixed anything.

Post has been edited 5 time(s), last time on Dec 22 2015, 7:17 pm by sigsaucy.




Dec 22 2015, 7:26 pm Roy Post #25

An artist's depiction of an Extended Unit Death

Quote from sigsaucy
Is there any chance that there is a problem with my router and I should just get a new one? Any suggestions on which one?
As someone who used to own that router I can tell you it isn't the problem. I can also tell you that it is a terrible router, though: I only got a throughput of about 22 Mbps.

I switched to a TP-Link Archer C8 and that fixed throughput speeds. Port forwarding was the same process for both routers, though, so if you can't get it working on your current router, you won't get it working on a new router.

Also, if you're bypassing the router and it still doesn't work, it's not the router's fault.




Dec 22 2015, 7:29 pm sigsaucy Post #26



Can you suggest a better one? I want to get a new one anyways.

If the router isn't the problem that leaves the modem/my computer/my isp as the possible problem points right?

if the modem is acting as a bridge and the isp says they don't close any ports then the problem has to be with my comp?

I've tried using my laptop to run a port test and it still says the port is closed

LAPTOP: macbook air OS X
Desktop: Windows 10

Post has been edited 2 time(s), last time on Dec 22 2015, 7:42 pm by sigsaucy.




Dec 22 2015, 8:18 pm sigsaucy Post #27



UPDATE: Success!!!!!!!

By using this program http://www.simpleportforwarding.com/ I now can play starcraft!!!

Oddly enough, when I use http://www.yougetsignal.com/tools/open-ports/ (with both my external and internal ip address) to check if 6112 is open it says it is closed but i can still log onto bnet no problem, but when the simpleportforwarding program runs the test it says its open.

I believe it probably ahs something to do with what IP address it is checking

the program has "IP to listen on" set to 192.168.8.100 and succeeds

where as at http://www.yougetsignal.com/tools/open-ports/ it uses my external ip address 50.1.38.XX and fails

Post has been edited 1 time(s), last time on Dec 22 2015, 9:29 pm by sigsaucy.




Dec 22 2015, 9:37 pm NudeRaider Post #28

We can't explain the universe, just describe it; and we don't know whether our theories are true, we just know they're not wrong. >Harald Lesch

Quote from sigsaucy
Oddly enough, when I use http://www.yougetsignal.com/tools/open-ports/ (with both my external and internal ip address) to check if 6112 is open it says it is closed but i can still log onto bnet no problem, but when the simpleportforwarding program runs the test it says its open.
That's because the program checks the TCP connection. The initial check is made on UDP. The program makes it so that YOU start the connection and thus circumvent the not open port. Some firewall (either in the router or the Windows one) seems to block port 6112 then.
Try https://pentest-tools.com/network-vulnerability-scanning/udp-port-scanner-online-nmap. It should reliably tell you whether the port is open or not. And it lets you check for UDP and TCP separately.

EDIT: Btw. online scanners can't scan your local IP (192.168...) because it's not routable over the Internet.

Post has been edited 1 time(s), last time on Dec 22 2015, 10:07 pm by NudeRaider.




Options
  Back to forum
Please log in to reply to this topic or to report it.
Members in this topic: None.
[08:35 pm]
Pr0nogo -- zz top
[06:28 pm]
NudeRaider -- Oh_Man
Oh_Man shouted: What happened to rockz
he's playing Elder Scrolls 4
[04:48 pm]
TF- -- doare-n pula
[11:07 am]
TF- -- muh blends
[08:25 am]
Oh_Man -- Last post feb that guy was a legend on the ums assistance forums *takes off hat*
[08:24 am]
Oh_Man -- What happened to rockz
[08:21 am]
jjf28 -- :wob:
[2019-9-19. : 1:45 am]
O)FaRTy1billion[MM] -- :wob:
[2019-9-19. : 12:13 am]
Oh_Man -- Daylight wobbery :wob:
[2019-9-18. : 11:56 pm]
razorback9423 -- :wob: :wob: :wob: :wob: :wob:
Please log in to shout.


Members Online: Roy, Oh_Man, akumydepy, razorback9423