Staredit Network > Forums > Modding Assistance > Topic: FireGraft 1.16.1 Button Set Issue
FireGraft 1.16.1 Button Set Issue
Sep 7 2011, 3:24 pm
By: Pr0nogo  

Sep 7 2011, 3:24 pm Pr0nogo Post #1



For some reason, whenever I save a FireGraft exe file and add in my custom MPQ, the custom button sets that I created in FireGraft are completely blank when I play the game, and when I open up the exe file again in FireGraft, they are blank. I've re-done the work countless times (before, it would still show up in-game, but now it doesn't). What's the issue?

By the way, the button sets that are becoming blank are entries 98, 99, and 100 (these are custom ones, obviously).




Sep 12 2011, 7:24 pm xAngelSpiritx Post #2

eternal lurker

Any chance you could send your mod to me and describe exactly what you're trying to do so I can reproduce it?

Without a closer look, my best guess is something got corrupted or broken. I doubt this is the cause, however, since I've added custom button sets in FireGraft before and they worked just fine.



None.

Sep 13 2011, 2:50 am Pr0nogo Post #3



Indeed, I had no problems with it until now. I'll PM you an FG file and instructions when I'm on my computer tomorrow.




Sep 13 2011, 11:52 pm Pr0nogo Post #4



I may have fixed it by making a new FireGraft file but I can't check until tomorrow. In other news, my iscript.bin has been corrupted.




Sep 14 2011, 12:53 am xAngelSpiritx Post #5

eternal lurker

Quote from Pr0nogo
In other news, my iscript.bin has been corrupted.
:|
But really, how did that happen? What kind of errors, if any, do you get? It might be fixable.



None.

Sep 14 2011, 7:11 pm Pr0nogo Post #6



I was using PyICE and it encountered an internal error whilst trying to save. I then found that my iscript.bin file was 0kB and wasn't added to my new .mpq or .exe, so I was effectively short one .bin file.




Sep 14 2011, 7:18 pm xAngelSpiritx Post #7

eternal lurker

Quote from Pr0nogo
I was using PyICE and it encountered an internal error whilst trying to save. I then found that my iscript.bin file was 0kB and wasn't added to my new .mpq or .exe, so I was effectively short one .bin file.
Isn't there still an iscript.bin file in your mod's .mpq, or its FireGraft .exe?



None.

Sep 14 2011, 8:09 pm Pr0nogo Post #8



No, like I said. I was adding the corrupted/blank 0kB file so it didn't work.

Don't matter because, in the end, it doesn't take much longer than an hour to re-do all that script-work, and I found a better way of implementing new shadows to boot. It all turned out for the better.

Gonna request that this stays open because I want to make sure FireGraft doesn't act up anymore. If it still is acting up, I'll post here again.

EDIT:

iscript.bin has been restored to a better state than before, but FireGraft is still reverting all edited button sets (buildings and the like) to their unedited states, and all new button sets have been wiped clean.

Angel, check your PMs.

Post has been edited 1 time(s), last time on Sep 14 2011, 9:12 pm by Pr0nogo.




Sep 14 2011, 10:58 pm Voyager7456 Post #9

Responsible for my own happiness? I can't even be responsible for my own breakfast

You're not doing something like editing files directly in the FIreGraft EXE at the same time as you're changing button sets, are you?



all i am is a contrary canary
but i'm crazy for you
i watched you cradling a tissue box
sneezing and sniffling, you were still a fox


Modding Resources: The Necromodicon [WIP] | Mod Night
My Projects: SCFC | ARAI | Excision [WIP] | SCFC2 [BETA] | Robots vs. Humans | Leviathan Wakes [BETA]


Sep 15 2011, 12:23 am Pr0nogo Post #10



Oh no, but I have the .mpq I load open in WinMPQ. Would that conflict?

It's weird because the DAT Requirements and Units sections aren't reverted, just the Button Sets sections.




Sep 15 2011, 12:28 am Voyager7456 Post #11

Responsible for my own happiness? I can't even be responsible for my own breakfast

No, the MPQ being open shouldn't be a problem. If the actual EXE were open in WinMPQ, that might be an issue.



all i am is a contrary canary
but i'm crazy for you
i watched you cradling a tissue box
sneezing and sniffling, you were still a fox


Modding Resources: The Necromodicon [WIP] | Mod Night
My Projects: SCFC | ARAI | Excision [WIP] | SCFC2 [BETA] | Robots vs. Humans | Leviathan Wakes [BETA]


Sep 15 2011, 1:03 am Pr0nogo Post #12



Nah, just the .mpq that FireGraft loads when I save it.




Sep 15 2011, 2:40 am xAngelSpiritx Post #13

eternal lurker

Thanks for the PM.

I've checked it out, and any attempt I make to even view the custom button sets causes FireGraft to report access violation errors and stop working. This, plus the fact that your file is mysteriously missing all EXE edits (even the non-working ones), leads me to believe that your mod's .fgd file is corrupted. My best guess as to the cause of this is that some data is missing from the file, as your .fgd's file size is considerably smaller than that of a clean .fgd.

I think you'll have to make a new EXE and redo the changes from scratch. While I would offer to try to uncorrupt your mod, AFAIK only DoA knows the .fgd format, so unless you can get a hold of him, no dice.



None.

Sep 15 2011, 4:01 am Pr0nogo Post #14



That is in fact the second tine I've started fresh with a clean mod. That mod was new when I PM'd you with it.

I assume, then, that I need to download a more recent release of FireGraft. I'm pretty sure my current version is the first translation DoA made from 1.15.1 to 1.16, and thus lacking in EXE Edits. I'll grab a more recent version and see what happens.




Options
  Back to forum
Please log in to reply to this topic or to report it.
Members in this topic: None.
[07:14 pm]
Kyradax -- Hi
[05:05 pm]
O)FaRTy1billion[MM] -- :wob:
[2024-5-25. : 9:22 am]
Zycorax -- :wob:
[2024-5-23. : 3:50 pm]
Ultraviolet -- :wob:
[2024-5-23. : 6:26 am]
UndeadStar -- :wob:
[2024-5-22. : 6:10 am]
Riney -- Somethings never change.
[2024-5-22. : 6:10 am]
Riney -- I come back after 4 months. Post wob. Make a crappy post in Null. Hit a 0 in magic boxes.
[2024-5-22. : 6:00 am]
Riney -- :wob:
[2024-5-20. : 3:08 pm]
Sylph-Of-Space -- woah! nice! thank you!
[2024-5-20. : 4:05 am]
O)FaRTy1billion[MM] -- the setting exists, it's just hidden in a weird place
Please log in to shout.


Members Online: Kyradax