Staredit Network > Forums > SC1 UMS Mapmaking Assistance > Topic: Increase Max Units
Increase Max Units
Sep 5 2007, 1:00 am
By: Fallen  

Sep 5 2007, 1:00 am Fallen Post #1



I was playing with my brothers on a tug of war map and the units kept maxing out so i did a quick fix that usually works: increasing map size and it didnt work. So i am asking is there a way to go about making max units bigger. I know of the option in a menue in scm draft but i wasnt sure if it was all that reliable or if would make the game crash if i did the wrong number.



None.

Sep 5 2007, 1:05 am Twitch Post #2



Do you mean reaching max units in game?If so there isn't a way to fix that.



None.

Sep 5 2007, 1:30 am Falkoner Post #3



The max amount of units on a map at a time is 1700, units will stop attacking well before that, since there is a much smaller sprite limit, these limits cannot be changed as they are just the limits of SC.



None.

Sep 5 2007, 2:07 am Clokr_ Post #4



Actually the image limit has to be a lot bigger than 1700. But each unit spawns 2 or 3 images (the graphic itself, the shadow, the attack bullets, the working building overlay, etc.), plus doodads also create images.

Making the unit limit bigger than 1700 you'd probably just get a lot of lag and the engine wouldn't work well.



?????

Sep 5 2007, 2:18 am LegacyWeapon Post #5



Simple answer: You can't.

Post has been edited 1 time(s), last time on Sep 9 2007, 1:28 am by LegacyWeapon.



None.

Sep 5 2007, 2:20 am Moose Post #6

We live in a society.

Quote from Fallen
quick fix that usually works: increasing map size
The max units is in no way dependant on the map size, it's a hard coded limit of StarCraft.




Sep 5 2007, 2:31 am Akar Post #7



Yep, they are correct. Maps can only be pushed to the engine's limits.



None.

Options
  Back to forum
Please log in to reply to this topic or to report it.
Members in this topic: None.
[2024-5-23. : 3:50 pm]
Ultraviolet -- :wob:
[2024-5-23. : 6:26 am]
UndeadStar -- :wob:
[2024-5-22. : 6:10 am]
Riney -- Somethings never change.
[2024-5-22. : 6:10 am]
Riney -- I come back after 4 months. Post wob. Make a crappy post in Null. Hit a 0 in magic boxes.
[2024-5-22. : 6:00 am]
Riney -- :wob:
[2024-5-20. : 3:08 pm]
Sylph-Of-Space -- woah! nice! thank you!
[2024-5-20. : 4:05 am]
O)FaRTy1billion[MM] -- the setting exists, it's just hidden in a weird place
[2024-5-20. : 4:04 am]
O)FaRTy1billion[MM] -- instead change "Microtile Overlay" to "Impassable"
[2024-5-20. : 4:04 am]
O)FaRTy1billion[MM] -- er, wait, idk why i was looking for height
[2024-5-20. : 4:03 am]
O)FaRTy1billion[MM] -- below the minimap should be a thing that says "Overlay Settings" with a little + button in the corner, press the + to expand it, uncheck Use Defaults, then change "Tile Overlay" to "Height"
Please log in to shout.


Members Online: Roy, RIVE