Staredit Network > Forums > Modding Assistance > Topic: building morph
building morph
Sep 20 2007, 11:40 pm
By: poiuy_qwert  

Sep 20 2007, 11:40 pm poiuy_qwert Post #1

PyMS and ProTRG developer

Im using FireGraft to try and make the Photon Cannon morph into a Templar Archives (which requires Shield Battery and Forge built). I set up the button to:
Can Create Unit\Building:
Templar Archives
Building Morph:
Templar Archives


And changed the Templar Archive Requirements to:
Current unit is...
Photon Cannon
Shield Battery
Forge
==End of List==


Then lastly went to EXE edits and changed the Building Morph Upper ID Bound to 163 (Citadel of Adun, right after Photon Cannon, ID 162). When I tested, the button was gray till i built the Shield Battery and Forge, but then when i clicked the button, nothing happened. Anyone know what im doing wrong?

Thanks!




Sep 21 2007, 3:48 pm Evien Post #2



Exe edits, building morph, ID Bounds perhaps? (Changing lower to 0 and upper to 228 should able to make morph work.) (Maybe..)



None.

Sep 21 2007, 8:17 pm Fyrinite Post #3



Check all the exe edits to make sure that you got everything. That's the biggest problem with them, is there's so many changes to get 1 simple effect. I tried my best with linking...but not as nice as I would've liked it.



None.

Sep 21 2007, 11:35 pm poiuy_qwert Post #4

PyMS and ProTRG developer

I looked through all the other EXE edits and didn't see anything else that looked like it would effect Building Morph. All the ID Bounds were changed, nothing else. I also havn't tried setting the ID bounds to 0 and 228, but I doubt it will work since Photon Cannon is in both ranges, i'll try it soon and edit this post.




Sep 22 2007, 6:23 am poiuy_qwert Post #5

PyMS and ProTRG developer

Well I found that adding a AlmostBuilt animation type would make it get further when i pressed the morph button, but it still didn't work completely. What would happen is the progress bar would start at full, then go back to nothing and start counting progress. When the bar completed the Photon Cannon had creep placed under, but stayed a Photon Cannon. I was then able to push the morph button again, resulting in the same progress bar behavior except when the bar was full it got stuck at full and i couldn't do anything with it.




Options
  Back to forum
Please log in to reply to this topic or to report it.
Members in this topic: None.
[04:28 am]
Doodan -- :shifty:
[04:27 am]
Doodan -- also :wob:
[04:26 am]
Doodan -- This helodieaodns guy sure likes WoW
[03:31 am]
KrayZee -- MTiger156
MTiger156 shouted: Starcraft: Nude War :wob:
Sounds like an ancient Greek battle set in the Starcraft universe.
[02:00 am]
lil-Inferno -- :wob:
[01:58 am]
MTiger156 -- Starcraft: Nude War :wob:
[01:11 am]
Ultraviolet -- :wob:
[12:16 am]
lil-Inferno -- :wob:
[05:13 pm]
MTiger156 -- Nude :bash: Me
[04:52 pm]
NudeRaider -- civil war!
Please log in to shout.


Members Online: Roy, jun3hong