Staredit Network > Forums > Modding Assistance > Topic: graphics questions
graphics questions
Sep 20 2007, 12:44 am
By: poiuy_qwert  

Sep 20 2007, 12:44 am poiuy_qwert Post #1

PyMS and ProTRG developer

I am trying to get the pylon to have the image of a creep colony. I went into DatEdit under the units tab, went to Zerg Creep Colony, copied the Graphics tab, and pasted it over the Protoss Pylon Graphics tab, and finish by changing Construction back to the first Scourge in the list. This caused it to crash when it was about to finish warping in, so i went into its iscript and made the WarpIn point to CreeepColonyBuilt. Now it finishes warping but the building is stuck on the process bar saying its not finished building. How can i fix it?

I used GRPEdit to write the bitmaps of a GRP to a folder, removed some of the images then tried to create a GRP with those frames but the pallette colors are wrong. This is probably very newby but why doesn't it work?

Is there a way to make users only able to select 2 of the 3 races and remove the 3rd from the list? Im guessing its only some BinEdit stuff.

Is it possible to change the position of where a worker will enter a tapped vespean geyser?

Thanks for your help!




Sep 20 2007, 1:52 am Fyrinite Post #2



The first problem sounds like a sigorder is missing from your iscript. The sigorder tell the game the unit is done with any iscript stuff during orders. IF you can't find the right value, put 255 to grap all possible values, but be warned, it might cause some side effects. The best bet is to try to find the right one.



None.

Sep 20 2007, 2:04 am poiuy_qwert Post #3

PyMS and ProTRG developer

There is no sigorder in the Pylon iscript though :/




Sep 20 2007, 3:11 am A_of-s_t Post #4

aka idmontie

What programs are you using for the GRPs?



Personal GitHub
Starcraft GitHub Organization - Feel free to request member status!
TwitchTV

Sep 20 2007, 3:22 am Fyrinite Post #5



Hmm. true. it could be that somewhere in the copy, the complete connection between overlays was lost...since I think all the protoss build's sigorders are in those...

anyway, try throwing one in at the beginning of the completed part of the iscript. almost every case I've ever heard of where the building is stuck right before finishing is due to the sigorder...



None.

Sep 20 2007, 3:31 am poiuy_qwert Post #6

PyMS and ProTRG developer

Aha, you were right, Thanks! Also, have any idea what things might happen using sigorder 255? or have any idea how to narrow down the order number?




Options
  Back to forum
Please log in to reply to this topic or to report it.
Members in this topic: None.
[04:17 am]
O)FaRTy1billion[MM] -- imagine having minerals
[2020-8-02. : 5:44 pm]
Dem0n -- ya I'm below 3100 smh
[2020-8-02. : 2:22 pm]
Wing Zero -- Ya
[2020-8-02. : 1:12 pm]
Voyager7456 -- seriously
[2020-8-02. : 12:56 pm]
lil-Inferno -- can these boxes fuccing give me some fuccing minerals already
[2020-8-02. : 12:56 pm]
lil-Inferno -- :wob:
[2020-8-02. : 12:22 pm]
Ultraviolet -- :wob:
[2020-8-01. : 8:55 pm]
MTiger156 -- :wob:
[2020-8-01. : 8:17 pm]
UndeadStar -- :wob:
[2020-7-30. : 9:53 am]
Ultraviolet -- C(a)HeK C(a)HeK
C(a)HeK shouted: Ultraviolet https://www.youtube.com/watch?v=yuH9cAvfOHA
Awesome! Unfortunately the Mercenaries video is just for normal Mercenaries not the 2020 version I made. But I watched the Mercs III video all the way through, it was a lot of fun to watch. He had some good feedback, I agreed with all of it.
Please log in to shout.


Members Online: Roy, Cerorec