PyMS
Jun 15 2008, 11:11 pm
By: poiuy_qwert
Pages: < 1 8 9 10 11 12 >
 

Feb 24 2009, 9:38 pm Keirebu Post #181



Quote from poiuy_qwert
Quote from Keirebu
Okay, Downloaded Newest Version, Here is what I got so far,

It tells me I'm out dated, even when I just downloaded the Newest Version.

PyLO, When you go to The File Association, And use it, It Sends the "The File Association has been set" message about 5-8 times o.o.

PyPal, Does the same thing with The File Association, But only sends the message 2 times.

More soon to come, ^-^.

It doesn't do any of that for me. You also said when importing a single bmp (vertical) in PyGRP made you press ok 50 times, but never answered my question: what os are you on?

So does anyone else have these problems?
Oh sorry, Windows XP SP2, o-o



None.

Feb 25 2009, 3:32 am ForTheSwarm Post #182



I try to open an aiscript file in PyAI, and I get:

Code
Exception in Tkinter callback
Traceback (most recent call last):
 File "Tkinter.pyc", line 1403, in __call__
 File "PyAI.pyw", line 2551, in <lambda>
 File "PyAI.pyw", line 2785, in move
IndexError: tuple index out of range


Also, I get the "not the latest version" error. Once (on the previous version), it said the newest one was version 98.89 or something. :lol:



None.

Feb 25 2009, 8:11 am poiuy_qwert Post #183

PyMS and ProTRG developer

Ok there is a version inconsistency which didn't appear to me because I had the version checks "Remind Me Later" disabled from the last version. The "not latest version" error has been fixed and the download has been updated with no version change, please redownload. This update also includes a fix for the "Remind Me Later" problem, and adds more checks to the version checker (explained bellow).

ForTheSwarm: That error is actually caused by using up/down/page up/page down/home/end in the script list when nothing is selected (or nothing is there). That has been fixed for the next version, just dont do it for now :P
The version thing you are talking about was because www.broodwarai.com went down for a while, so it was giving an error page instead of version info. There is no definite way for me to stop it from fooling PyMS into thinking there is a new version, but i added some additional checks so its unlikely this will happen again.




Mar 26 2009, 3:33 am poiuy_qwert Post #184

PyMS and ProTRG developer

PyMS v1.2.0 has been released. Some highlights from the changes are:

General:
-Totally revamped MPQ and settings handling. This also means no PyMS program should ever hog your MPQ's anymore
-On Windows all resizeable programs now save their maximized state between uses
PyAI:
-PyAI now keeps track of your aiscript.bin and bwscript.bin's file sizes and displays them in the statusbar
-The Script Editor now shows at most 5 of the script ID's (that were selected when it was opened) in its title
PyGRP:
-You can now select multiple bmp's to import instead of being stuck with the "same name" mechanic (which PyGRP uses for the command line bmp to grp conversions)
-Added a "Transparent Index" option (like SFGrpConv) to choose which index in the palette will be used for transparency (can only be changed when a GRP is not open)
-You no longer need to specify if you are loading an uncompressed grp, only if you are saving to one
PyICE:
-The IScript Editor now shows at most 5 of the script ID's (that were selected when it was opened) in its title
-The IScript Entries list now only shows entries that are actually in the file
-Added support for custom IScript ID's greater then the default iscript.bin's highest ID
-Added a new special header extension (like the GRP frames extension from v1.5) to define a custom name for IScript entries
PyLO:
-Updated the previewer, now it is located in the main window, can preview GRP's, and allows drag and drop for changing offsets
PyTBL:
-Added a text previewer
-Added the color list to the main window and removed the colors window
PyTILE:
-Added tile Group, MegaTile, and MiniTile Importing/Exporting to the Tile Palette window

As well as lots of bug fixes. I highly recommend updating!




Mar 26 2009, 4:12 am thunderaga Post #185



FINALY!!!
I was waiting for the importing of the tiles.
before I had to use Hawt Tiles (Beta)

Thank you for the updates



None.

Mar 31 2009, 11:14 pm poiuy_qwert Post #186

PyMS and ProTRG developer

Well I'm glad you like it.

Also, if anyone is thinking of making fonts, I created a little program to generate PyFNT compatable BMP's from a TTF. The program is called FNTGen, and it can be downloaded from here (in the PyMS forums). There is no plan to add this feature directly to PyFNT because of its size and some other reasons, but that might change if people want it.




Apr 1 2009, 12:22 am Biophysicist Post #187



I want it...

Anyway. Cool update, thanks poiuy.

Oh, I just downloaded PyMS and like it a lot. PMS FTW!

Post has been edited 1 time(s), last time on Apr 1 2009, 1:05 am by TassadarZeratul.



None.

Apr 2 2009, 2:03 pm ForTheSwarm Post #188



PyAI keeps renaming one of my blocks. I name it "Defense" and save, but when I reopen it, the block is renamed to the first block ("Start"). This happens every time.



None.

Apr 2 2009, 10:54 pm poiuy_qwert Post #189

PyMS and ProTRG developer

Im glad you like it TassadarZeratul.

ForTheSwarm: Please post up the aiscript.bin and bwscript.bin (if its used), and give step by step instructions to reproduce it please. Thanks for the report.




Apr 3 2009, 2:27 am ForTheSwarm Post #190



1. Open up the aiscript.
2. Open up Terran Expansion Level (Ender TvZ)
3. Click "Check for Errors". A popup saying something about a block already being named "Start" should appear.
4. Rename the highlighted block to "Defense" and all instances of goto(Start) EXCEPT for the first one (near start_campaign).
5. Save and reopen the file.

also, locunlock set shields pl0x?

Attachments:
aiscript.bin
Hits: 1 Size: 51.56kb

Post has been edited 1 time(s), last time on Apr 5 2009, 2:43 pm by ForTheSwarm.



None.

Apr 8 2009, 12:07 am HailFire Post #191



This application has failed to start because the application configuration is incorrect. Reinstalling the application may fix this problem.

^ Whenever I try to run any of the PyMS .exe files.

I downloaded the .zip file, cut/pasted it from my desktop to my modding tools folder, and "Extract Here"'d it with WinRAR.



None.

Apr 8 2009, 12:10 am poiuy_qwert Post #192

PyMS and ProTRG developer

Very odd. Have you tried redownloading? What windows version are you using? What is the layout of your PyMS folder?




Apr 8 2009, 12:20 am HailFire Post #193



Quote from poiuy_qwert
Very odd. Have you tried redownloading? What windows version are you using? What is the layout of your PyMS folder?

-Not yet, but I will.
-XP
-Screenshot:

Attachments:
blergh.bmp
Hits: 3 Size: 1396.94kb



None.

Apr 8 2009, 12:29 am poiuy_qwert Post #194

PyMS and ProTRG developer

Hmm... Looking around google, one other person had the same issue and it seems it may be caused by using a newer version of Python to compile the EXE's. Supposedly "This will be due to the C runtime library not being installed correctly on the target machine." I have no idea about this, but if redownloading doesn't work I'll recompile it on the older version to see if that works for you.




Apr 8 2009, 12:34 am HailFire Post #195



Deleted, re-downloaded, un-packed, no change.

All within the space of a minute. :ermm:



None.

Apr 8 2009, 12:48 am poiuy_qwert Post #196

PyMS and ProTRG developer

Alright try this dl. I recompiled them with the older version so it should work, but If it doesn't i'll have to do some more looking around...




Apr 8 2009, 12:56 am FlyingHat Post #197



That text previewer is very, very nice.



None.

Apr 8 2009, 1:04 am HailFire Post #198



Seems to work now, thanks.



None.

Apr 8 2009, 1:18 am poiuy_qwert Post #199

PyMS and ProTRG developer

Yay, im glad it works.

FlyingHat: Glad you like it :)




Apr 8 2009, 3:02 am Biophysicist Post #200



Quote from ForTheSwarm
also, locunlock set shields pl0x?
Actually, I'd like this too.



None.

Options
Pages: < 1 8 9 10 11 12 >
  Back to forum
Please log in to reply to this topic or to report it.
Members in this topic: None.
[10:40 am]
IlyaSnopchenko -- Prolly changed a couple of formats around again, too...
[10:39 am]
IlyaSnopchenko -- Effin rodents
[10:38 am]
Suicidal Insanity -- If nobody else does before then
[10:37 am]
Suicidal Insanity -- Will have to check after work
[10:36 am]
IlyaSnopchenko -- Ew... if it's breaking compatibility again, I'm not setting it up for a while.
[10:34 am]
IlyaSnopchenko -- What's going on? Do we have a new patch out?
[10:22 am]
Suicidal Insanity -- I haven't tested with the latest update, I would hope blizzard stopped randomly breaking it :(
[03:05 am]
jjf28 -- o and it's an anti-hack update, coo
[03:05 am]
jjf28 -- o, updated like half a day ago, but idk
[02:35 am]
RdeRenato -- scmdraft not working since last SCR update?
Please log in to shout.


Members Online: Roy, Suicidal Insanity, KrayZee, Dem0n, qPirateKing, ProtoTank