Staredit Network > Forums > Modding Discussion > Topic: Winmpq problem
Winmpq problem
Nov 24 2016, 7:53 pm
By: Rawflesh0615  

Nov 24 2016, 7:53 pm Rawflesh0615 Post #1



When I was trying to switch my starcraft stuff from Windows 8 to Windows 10. I decided to open my Winmpq for my starcraft custom campaign project until I got this stupid error said, "Can't load (or register) custom control: 'mscomctl.ocx.' I have no idea what to di? What should I do? I tried to uninstall my Starcraft from Windows 8 but it didn't work. How should I fix this error? Can you give me some clear explanation?



None.

Nov 24 2016, 8:45 pm CecilSunkure Post #2



Just a wild guess: did you open all programs in administrator mode? Is your file mscomctl.ocx in the right place? To me it sounds like a rights/privileges problem. Have you tried this sort of thing: https://answers.microsoft.com/en-us/windows/forum/windows_7-windows_programs/component-mscomctlocx-or-one-of-its-dependencies/4ae4dfc4-4a67-4927-990e-489cdb070efb ?



None.

Nov 24 2016, 9:50 pm Rawflesh0615 Post #3



I already followed the instruction from the link from below. Until, I got this another error again. When I finally got the instruction from the Command Prompt for typing the code. The another error popped out, and it said, "The module "MSCOMCTL.OCX" failed to load. Make sure the binary is stored at the specified path or debug it to check for the problems with the binary or dependent .DLL files The Specified module could not be found."

This is getting more tricky I guess.



None.

Nov 24 2016, 11:34 pm Rawflesh0615 Post #4



Also, I am using Windows 10.



None.

Nov 25 2016, 4:18 am Corbo Post #5

ALL PRAISE YOUR SUPREME LORD CORBO

You need that dll controller and you need to register it. Download the dll mscomctl.ocx from the internet (it is a pretty common download) and you need to register it. I assume you are on a 64 bit system.

I will link you to a tutorial for registering it on a 64 bit system later on as I cannot right now.

EDIT: This: https://support.microsoft.com/en-us/kb/2746232

Make sure the dll is in the correct path, although I am pretty sure you can just register it from any path.

Post has been edited 1 time(s), last time on Nov 25 2016, 5:19 am by Roy. Reason: Friendly reminder is unnecessary



fuck you all

Options
  Back to forum
Please log in to reply to this topic or to report it.
Members in this topic: None.
[11:13 pm]
Suicidal Insanity -- There was a blue post to that effect, why would it be silly?
[08:37 pm]
NudeRaider -- Suicidal Insanity
Suicidal Insanity shouted: to do with the fact that macos is phasing out 32bit support
that would be silly but might still be true
[08:33 pm]
jjf28 -- there was a neat trick in 1.16.1 with the sprite structure... though it's not in SC:R
[07:43 pm]
Zoan -- I'll try it when I get home
[07:30 pm]
Zoan -- anyone know how to make selection persist through walking in fog of war with eud's? http://www.staredit.net/topic/7729/unread/#special
[02:17 pm]
Suicidal Insanity -- to do with the fact that macos is phasing out 32bit support
[02:17 pm]
Suicidal Insanity -- NudeRaider
NudeRaider shouted: The changes are all "under the hood" main reason for 64 bit is access to more than ~3.5GB RAM. Probably not relevant to Starcraft though.
it may, just maybe, just a littgle, havet
[2019-10-22. : 5:07 am]
NudeRaider -- Ultraviolet
Ultraviolet shouted: NudeRaider <3
even though I clearly put no effort into those arrows? :P
[2019-10-22. : 5:06 am]
NudeRaider -- http://i.snipboard.io/k3C9O2.jpg ... because all the main characters suffocated during this scene
Please log in to shout.


Members Online: Roy, Ahli, giovannyiwilson, Owse2