Staredit Network > Forums > SC2 Assistance > Topic: Randomize Players + Fix Screenshots
Randomize Players + Fix Screenshots
Nov 21 2012, 5:28 pm
By: payne  

Nov 21 2012, 5:28 pm payne Post #1

:payne:

Somehow, in Player Properties, all my players have "Random Start Location" allocated to them as their start location. However, they always get to spawn as the same players. How do I make it so that their player number is randomized?

And somehow, the screenshots I had uploaded in the map are gone from the Important module, and on B.net they are shown as pitch black pictures... and I can't find them on my computer anymore. Any ideas on how to get them back from within the map?



None.

Nov 21 2012, 5:35 pm DevliN Post #2

OVERWATCH STATUS GO

"Random Start Location" only randomizes where they start on the map. I don't think you can randomize their player number as that's set in the lobby. What do you want to randomize it for? You can probably cheat it if you wanted by randomizing the player colors (so it looks like they have changed) and then set up variables as the new player numbers.



\:devlin\: Currently Working On: \:devlin\:
My Overwatch addiction.

Nov 21 2012, 5:49 pm payne Post #3

:payne:

Quote from DevliN
"Random Start Location" only randomizes where they start on the map. I don't think you can randomize their player number as that's set in the lobby. What do you want to randomize it for? You can probably cheat it if you wanted by randomizing the player colors (so it looks like they have changed) and then set up variables as the new player numbers.
I have pre-placed a bunch of units on the map for 4 players. As it is right now, the host will always get the same units. I'd like the host (and other players) to get to try the other unit-combos as well.



None.

Nov 21 2012, 6:32 pm DevliN Post #4

OVERWATCH STATUS GO

Make the units owned by the neutral player, put regions around each group, and randomize who gets them at the start. Or create the groups via triggers, instead, and randomize who gets them.



\:devlin\: Currently Working On: \:devlin\:
My Overwatch addiction.

Nov 25 2012, 9:34 pm payne Post #5

:payne:

And for screenshots. Do you know how they could have gone to pure black pictures? The files are indeed now absent from the Import module, but how did they get erased?
Also, when I tried uploading some the first time, I remember there was this 800x600 obligatory image size. How comes people are able to publish square images?
My process was: take screenshot, resize to 800x600, add a black area to cover the blank area that's now created by the resize.



None.

Nov 25 2012, 10:40 pm Ahli Post #6

I do stuff and thingies... Try widening and reducing the number of small nooks and crannies to correct the problem.

If the pictures aren't in the import module, even with "reserved" files displayed, they aren't inside the map file.




Nov 26 2012, 12:40 am payne Post #7

:payne:

Quote from Ahli
If the pictures aren't in the import module, even with "reserved" files displayed, they aren't inside the map file.
How could they have disappeared? Because they used to be there. :/



None.

Nov 27 2012, 2:35 am payne Post #8

:payne:

And I reuploaded the screenshots. They are now fine.

-But- I had to fix their size once again. Reduced them to 800x600, but it's not the same ratio as the one I play, so I had to fill the space with a blank area again. How comes I seem to be the only one required to do that? How do others upload their full-sized images? :/



None.

Dec 2 2012, 11:01 pm payne Post #9

:payne:

What the F*!

Once again, my screenshots got removed for no apparent reason. They were there last time I opened and published the map. Now, they are gone once again. >_>
What is wrong with the map? :(

EDIT: Screenies.



Post has been edited 2 time(s), last time on Dec 2 2012, 11:14 pm by payne.



None.

Dec 2 2012, 11:23 pm Ahli Post #10

I do stuff and thingies... Try widening and reducing the number of small nooks and crannies to correct the problem.

Did you always import them to a folder with a number as name?

If yes, it might be a bug that you can report. Maybe you can test this and try to recreate this bug.




Dec 3 2012, 2:24 am payne Post #11

:payne:

Quote from Ahli
Did you always import them to a folder with a number as name?

If yes, it might be a bug that you can report. Maybe you can test this and try to recreate this bug.
Nope.
Not sure if I imported them without a folder before. I believe that's how it was the first time I uploaded them.

EDIT: Just realized it's saying the image is "800x450". I uploaded them as 800x600, but from a 800x450 because I had to reduce the initial resolution which was too big. The first time, I then added a black area to fill the gap at the bottom. This last time, I added nothing because I thought the default-white in Paint was fine enough.
Does the PNG extension compress the file a certain way that could prevent the editor to realize it's 800x600 or something?

Post has been edited 1 time(s), last time on Dec 3 2012, 2:31 am by payne.



None.

Dec 19 2012, 5:45 am payne Post #12

:payne:

Once again, this annoying bug hits home.

And this time, it's on a totally different map, and the screenshots were legit 800x600 shots (no added single-color region to fill an empty space). However, I once again used Paint to select a 800x600 region from the initial screenshots.

No one else is experiencing this?



None.

Dec 19 2012, 9:54 am Ahli Post #13

I do stuff and thingies... Try widening and reducing the number of small nooks and crannies to correct the problem.

Quote from payne
Once again, this annoying bug hits home.

And this time, it's on a totally different map, and the screenshots were legit 800x600 shots (no added single-color region to fill an empty space). However, I once again used Paint to select a 800x600 region from the initial screenshots.

No one else is experiencing this?

Can't you just use the tool in the arcade info window where you can select those images?
It transforms an image to tga, lets you chose an area of 800x600 within the pic and lets you control where black borders are added.
I used it and it worked fine.

Else, you could post that with the exact steps to recreate on Blizzard's new mapmaking/editor forums.




Dec 19 2012, 10:34 am payne Post #14

:payne:

Quote from Ahli
Can't you just use the tool in the arcade info window where you can select those images?
It transforms an image to tga, lets you chose an area of 800x600 within the pic and lets you control where black borders are added.
I used it and it worked fine.
What the hell, where is that goddamn tool? :0_o:



None.

Dec 23 2012, 5:54 am payne Post #15

:payne:

Same question: where is that tool?. :/



None.

Dec 23 2012, 1:58 pm Ahli Post #16

I do stuff and thingies... Try widening and reducing the number of small nooks and crannies to correct the problem.

Quote from payne
Same question: where is that tool?. :/

It's the folder button with the tooltip "import screenshot".
After selecting a picture from your computer, it opens it in a small editor where you can select the used 800x600 area. Then it imports that as .tga into your map file.




Dec 24 2012, 10:55 pm payne Post #17

:payne:

Quote from Ahli
Quote from payne
Same question: where is that tool?. :/

It's the folder button with the tooltip "import screenshot".
After selecting a picture from your computer, it opens it in a small editor where you can select the used 800x600 area. Then it imports that as .tga into your map file.
That's going to save me so much work in the futur. Thank you. :3



None.

Options
  Back to forum
Please log in to reply to this topic or to report it.
Members in this topic: None.
[12:43 am]
jjf28 -- KrayZee
KrayZee shouted: Fast forwarding 24 years later, I just felt a little nostalgic about it. Instead you responded like an asshat
:peach: :hat:
[10:41 pm]
lil-Inferno -- memes brother
[10:30 pm]
KrayZee -- Fast forwarding 24 years later, I just felt a little nostalgic about it. Instead you responded like an asshat
[10:28 pm]
KrayZee -- I know that's the point... I just never heard of this website until now and I don't get late 90s vibes with SEN.
[09:57 pm]
Slyence -- Dem0n
Dem0n shouted: wow it's almost like that's the point
I literally lold
[09:14 pm]
Dem0n -- wow it's almost like that's the point
[08:03 pm]
KrayZee -- Dem0n
Dem0n shouted: https://bounding.net/ is the best source for maps
Feels like late 90s and early 2000s with the layout and StarCraft 1 theme.
[2022-1-15. : 11:46 pm]
Slyence -- :(
[2022-1-15. : 11:46 pm]
Slyence -- string thumbsUp = " :thumbsup: ");
[2022-1-15. : 11:45 pm]
Slyence -- string thumbsUp = ":thumbup:");
Please log in to shout.


Members Online: Vandogt3, Roy, TheHappy115