Staredit Network > Forums > Modding Assistance > Topic: [Tutorial] Giving a Unit Cloaking
[Tutorial] Giving a Unit Cloaking
Feb 27 2015, 10:48 pm
By: Sand Wraith  

Feb 27 2015, 10:48 pm Sand Wraith Post #1


by Sand Wraith
tested for StarCraft Brood War 1.16.1.

I wanted to make the Unclean One cloak.
The Unclean One does not originally have cloaking capabilities.
I will add this capability such that it correctly mimics other examples of cloaking.
I will use Cloaking Field (instead of Personal Cloaking) in this example.
I am logging all changes I perform to provide insight into giving a unit the capability of cloaking.
The arbitrary unit in question does not originally have cloaking capabilities.

I have included "1161.fgd." It is necessary to provide Firegraft the memory locations to alter to apply the Exe edits.

units.dat ** ** marked Unclean One as "Cloakable." Ensured it was a "Spellcaster."
firegraft ** ** gave defiler + heroes button set "Cloak" and "Decloak" buttons from the Wraith, set to position 3 (for ease of use in this case).
firegraft ** ** Use Tech: Cloaking Field. Added "Or, Current unit is..., Unclean One"
firegraft ** ** Exe Edits: Cloak. All variables regarding "Use Cloaking Field" are set to "Enabled"
starcraft ** ** testing.

Unclean One cloaks and decloaks on command as desired.
Unclean One decloaks upon burrowing (stops draining energy). Decloak button remains, but resets to Cloak button upon unburrowing.
Upon unburrowing after burrowing while cloaked, Unclean One remains uncloaked.
Unclean One decloaks when running out of energy as desired.

Included is a binary with the changes listed for easy testing and verification.

Hits: 6 Size: 293.35kb

Post has been edited 1 time(s), last time on Feb 28 2015, 12:44 am by Sand Wraith.

Feb 27 2015, 11:32 pm SCRuler Post #2

You know what, I can't for the life of me figure out what I'm doing wrong. I did all the steps. It still won't function properly. it doesn't decloak and the energy doesn't drain properly.
I included the files that are key in my mod. They have the setup I have right now including your wonderful plugin. If you take a look, you'll probably see what I got done wrong or am missing.


Feb 28 2015, 12:29 am Sand Wraith Post #3


I opened your NewModAttFG.exe in Firegraft and checked the Cloak requirements.

(Should be Enabled.)

(Should be Enabled.)

It's not consistent.

Feb 28 2015, 12:33 am SCRuler Post #4

I dont have those options on mine... ugh. Do i need a new version of Firegraft? Yours is 1.16 right? Link please?


Feb 28 2015, 12:47 am Sand Wraith Post #5


I'm using 1.16.1 for SCBW but I have an updated *.fgd file for this version.

My bad, I thought I included the test package here, but I forgot to attach it. It is in the OP now. It includes the 1161.fgd file that you will need. Simply replace the 1161.fgd file that you have in your Firegraft directory and you should see it.

Feb 28 2015, 1:00 am SCRuler Post #6

Edit: Ok, I went and downloaded a new version of Firegraft (the 11/15/13 version) and I have the new list items.

Post has been edited 1 time(s), last time on Feb 28 2015, 1:14 am by SCRuler.


Feb 19 2016, 9:31 pm Shyster Post #7

Tried this, didn't do anything for me. :( I am trying to cloak an Arbiter, instead of them using their original cloaking field. I originally wanted to have them cloak while idle, but it may not be possible for all i know.

I compared all the fields between mine and yours, they are all the same and this is not difficult. Yet I have NO button whatsoever...

I changed it from Cloak Mixed (no idea what Mixed meant anyway) to just Cloak and now I have a button again, but it is greyed out. As with all my previous attempts before finding this thread, enabling it with medieval man just gives you a cloak button that always tells you not enough energy and with cheats it does nothing when cilcked.

Your files worked just fine for me so it's obviously my fault, but I'm pretty confused because the instructions were simple.


Edit: I even tried it on your files instead of mine, this simply does not work on the Arbiter.

Post has been edited 3 time(s), last time on Feb 19 2016, 10:26 pm by Shyster.


Feb 21 2016, 8:57 pm Sand Wraith Post #8


There might be an issue with the Arbiter being able to cloak. Try using another unit for now. It might also be a conflict with the AI orders of the Arbiter, since I vaguely recall the Arbiter having different idle AI orders than most units.

Feb 21 2016, 9:07 pm SCRuler Post #9

There's something about allowing the arbiter t cloak in the exe edits last I checked


Feb 21 2016, 9:18 pm Pr0nogo Post #10

Arbiter has a cloak AI order which is probably related to why this doesn't work.

Feb 23 2016, 10:38 pm Shyster Post #11

I figured it had something to do with the particular unit. The reason I wanted to add a manual cloak is I removed the cloaking field script from its orders...which actually brings me to another oddity I discovered:

I played a couple extremely long vs. AI games and noticed the script to cloak nearby units somehow came BACK. Weird as hell, can't think of how on earth that happened. Another strange thing is in one of those games, it eventually shut itself off again and no longer cloaked nearby units. My Arbiter is a bit more like a Protoss Tempest so I removed the cloak field order to help balance. But I have no explanation for why the script somehow returned, which is kind of an even bigger problem than not knowing how to cloak it manually - I could live with that and try on another unit as you said.

Quote from SCRuler
There's something about allowing the arbiter t cloak in the exe edits last I checked

I'm not quite sure what I'd be looking for, but I never found anything like you describe. Can you elaborate on this? <3


Feb 24 2016, 2:13 am Pr0nogo Post #12

If you go into FireGraft and check for cloak references in the EXE edits tab, you should eventually find something that might help. Alternatively, check the script manually by using some AI editing programme and see if you can remove it bit by bit. It could be hardcoded but FireGraft can combat that to some degree.

  Back to forum
Please log in to reply to this topic or to report it.
Members in this topic: None.
[12:43 am]
jjf28 -- KrayZee
KrayZee shouted: Fast forwarding 24 years later, I just felt a little nostalgic about it. Instead you responded like an asshat
:peach: :hat:
[10:41 pm]
lil-Inferno -- memes brother
[10:30 pm]
KrayZee -- Fast forwarding 24 years later, I just felt a little nostalgic about it. Instead you responded like an asshat
[10:28 pm]
KrayZee -- I know that's the point... I just never heard of this website until now and I don't get late 90s vibes with SEN.
[09:57 pm]
Slyence -- Dem0n
Dem0n shouted: wow it's almost like that's the point
I literally lold
[09:14 pm]
Dem0n -- wow it's almost like that's the point
[08:03 pm]
KrayZee -- Dem0n
Dem0n shouted: is the best source for maps
Feels like late 90s and early 2000s with the layout and StarCraft 1 theme.
[2022-1-15. : 11:46 pm]
Slyence -- :(
[2022-1-15. : 11:46 pm]
Slyence -- string thumbsUp = " :thumbsup: ");
[2022-1-15. : 11:45 pm]
Slyence -- string thumbsUp = ":thumbup:");
Please log in to shout.

Members Online: Vandogt3, Roy, TheHappy115