Staredit Network > Forums > SC1 Mapping Tools > Topic: File Strangeness
File Strangeness
Feb 25 2017, 11:19 am
By: sigsaucy  

Feb 25 2017, 11:19 am sigsaucy Post #1

So, after a long absence I decided to edit a map of mine.

There's 2 things that are happening
1) When I run scmdraft2 as admin, any edits I perform to my map and try to save result in scmdraft crashing without saving my changes.
2) When I don't run it as admin, any edits I perform seem to be saved fine, but when I try to load them with other programs they don't exist.

What is going on? I'd really like to work on my map but this makes it seem like everything is broken. Is my file corrupted or something? Am I out of luck?

Roberts Rebellion.scx
Hits: 3 Size: 324.71kb

Post has been edited 2 time(s), last time on Feb 25 2017, 11:46 am by sigsaucy.

Feb 25 2017, 12:00 pm Ahli Post #2

I do stuff and thingies... Try widening and reducing the number of small nooks and crannies to correct the problem.

Can you try to remove some old backups from scmdraft's backup DB? (In case scmdraft crashes during that, move backupDB.scmdDB from the scmdraft out of the folder or rename it, so scmdraft doesn't use the backup database anymore. If that does not fix the problem, you can put it back in, so you do not lose potentially working backups of your maps.)

Editing things, saving and re-opening the map seems to work fine for me.

Feb 25 2017, 12:04 pm Sie_Sayoka Post #3

It works fine for me in scmd2 and doesn't seem corrupted.

You can try to reinstall scmd2. What other programs are you using?


Feb 25 2017, 12:51 pm NudeRaider Post #4

We can't explain the universe, just describe it; and we don't know whether our theories are true, we just know they're not wrong. >Harald Lesch

The reason ScmDraft can't save the changes to your map is because Windows' system file protection mechanism. Legacy programs that were programmed before this feature existed (the case with ScmDraft) that are not run with admin priviledges can't write, among other folders, to "program files", Windows, etc.

So I'm assuming StarCraft is installed under "program files (x86)" so ScmDraft can't access it. A simple fix that avoids similar problems in the future would be to move both StarCraft and ScmDraft to a custom folder. "C:\Games", for example.

As for the crashing issue, unfortunately there are a number of "not entirely stable" ScmDraft versions around. They are all named 0.82 or 0.81.
It might be enough to open the map in ScmDraft 0.73 or any Starforge version, save it under another name and then open it in your current ScmDraft.

Another common issue that crashs ScmDraft is that your Backup Database got corrupted. Look for "backupDB.scmdDB" in your ScmDraft folder. If it's >1GB rename it. (nvm Ahli already mentioned it)

Feb 26 2017, 5:42 am sigsaucy Post #5

looks like a combination of removing the backup file and running as admin has solved my problem. Thanks!

  Back to forum
Please log in to reply to this topic or to report it.
Members in this topic: None.
[03:17 pm]
Pr0nogo -- u
[02:35 pm]
lil-Inferno -- u
[02:02 pm]
Corbo -- No
[01:28 pm]
razorback9423 -- Um, is this shoutbox active?
[2019-9-14. : 11:18 am]
razorback9423 -- C.I.S. Conversion Mod will have a campaign, and the first part is coming this September.
[2019-9-13. : 12:03 am]
Wing Zero -- Memes
[2019-9-12. : 8:36 pm]
KrayZee -- I'm curious what internet archaeologists will find in Maplantis
[2019-9-12. : 5:17 pm]
MTiger156 -- Moral of the story - don't end up like Friendster
[2019-9-12. : 3:53 am]
Pr0nogo -- Voyager7456
Voyager7456 shouted: kill you opponent
Zoan shouted: this map was boring as far as I remember lol
Please log in to shout.

Members Online: Roy, Doodan, ozellochoa, KrayZee