Staredit Network > Forums > Modding Assistance > Topic: Weird Iscript
Weird Iscript
Jun 2 2009, 12:55 am
By: Lord_Jeremy  

Jun 2 2009, 12:55 am Lord_Jeremy Post #1



Well here I am with yet another problem... Sorry for being such a bother :(

I'm trying to disassemble someone else's mod to figure out how they did something. This should just simply involve extracting the arbiter entry from their iscript.bin, but the latest IceCC fails to do so. It reports "unknown opcode 0x54 read at 0x004d (block start: 0x0000004d)". As far as I know this is a very old mod, from the days of cwads and stargraft (see my previous post :P). I can probably figure out what I need to do without looking at this script, but it would definitely be helpful. I've attached the problematic iscript.bin... Thanks!

Attachments:
iscript.bin
Hits: 1 Size: 40.88kb



None.

Jun 2 2009, 1:09 am Polaris Post #2



If it's that old, then it was probably made with ICE, which is why IceCC can't open it. I don't think there's any way to view ICE iscripts in IceCC, but I might be mistaken, as I've never tried it.



If anything cool is ever going on Skype me up under the name "blarghle"

Jun 2 2009, 1:46 am Lord_Jeremy Post #3



Oh right, I completely forgot about ICE. I'll see if I can open it with that. Thanks!



None.

Jun 6 2009, 10:58 pm Lord_Jeremy Post #4



Interesting.... it seems this iscript uses the "Terran Lift-Off" animation set even though it's a protoss unit (not a lift-offable building afaik). Also, under that "Terran Lift-Off" header, there's a bunch of entires called "Unidentified Op > 0x41. See Readme file. Assuming len=1" as well as a couple other entries that don't make much sense. (i.e. turning the graphic 119 units clockwise and playing frame 29268.) Also, the script uses animation sets "Unknown 7" and "Unknown 8". Does anyone know what those headers are for and what they translate to in modern IceCC language?

Maybe someone more knowledgeable than I could take a look at the script and figure out exactly what's going on with that gobbledegook under the "Terran Lift-Off" header...



None.

Jun 7 2009, 3:17 am Sand Wraith Post #5

she/her

I'm curious as to what mod you're taking apart.

IceCC comes with some documents that you can read to identify some of the unknown headers. However, some of them truly are -- I just can't confirm if Unknown 7 and Unknown 8 are really unknown.




Jun 7 2009, 3:34 am poiuy_qwert Post #6

PyMS and ProTRG developer

Sounds like your iscript.bin is corrupt.




Jun 7 2009, 3:45 am ShadowFlare Post #7



There aren't really any unknown headers. By the way, that Lift Off animation is probably not really Lift Off. I recall that being one of the animations that was mislabeled in ICE and IceCC (could have been lift off in an older version of SC, maybe). Also, there is a certain order for the animation headers by default (though you can rearrange the order in IceCC after decompiling). The order might match up between ICE and IceCC.



None.

Jun 7 2009, 3:18 pm FlyingHat Post #8



Don't have anything to do with ICE. Never use ICE, and don't even bother getting close to it.
It will corrupt anything it touches including your house.



None.

Jun 7 2009, 5:12 pm Lord_Jeremy Post #9



Damnit, I'm not making any changes to the script with Ice, I'm just reading an old iscript to try and recreate the usage of the frames of a unit GRP. The unit has like 300 frames so just looking at the GRP was proving a challenge. The mod is a little grp mod that turns the Protoss Arbiter into a Protoss Tripod. I seriously want to use the tripod GRP because it fits what I need. Odd that Ice would corrupt the script just by opening it... Oh well I guess I can't go that route. I'll figure the rest out by looking at the damn frames >.<



None.

Jun 7 2009, 9:05 pm EzDay281 Post #10



Eh, it's not necessarily even 'corrupt'. The one time I complained that ICE had corrupted a file of mine, I found out after a couple hours' work what I had fucked up. And I used ICE a lot ( doing pretty much as much as I could with it, given that it can't handle a nice assload of fun opcodes, including such things as spr/imgol/ul... )
More likely, if I understand iscript.bin and ICE/IceCC correctly ( my guesses being entirely based on inference, so I'm not gonna trust 'em much ) , there's an opcode in the script which is actually of a different bit length than ICE's reference file, so everything after it is read incorrectly.
But the end-result is the same: You can't read it, possibly unless you make some changes to opcodes.ini, though even if that works it'd probably be too much trouble. And, of course, there's always the possibility that it is, in fact, corrupt.



None.

Jun 7 2009, 9:13 pm poiuy_qwert Post #11

PyMS and ProTRG developer

No, ICE definitely does corrupt files. Not only does it do what you said (incorrect opcode specs, which result in invalid loading and compiling, which results in a "corrupt" file), but it does a lot of stuff that is just retarded. Do not use ICE. Even if you "think" its not corrupting your file, it is, and it will get worse with every save you make (probably).




Jun 7 2009, 9:21 pm ForTheSwarm Post #12



There's no good reason to use ICE anyways, when you have IceCC and PyICE, both of which have more functionality and don't corrupt your iscript.



None.

Jun 7 2009, 10:39 pm Lord_Jeremy Post #13



Yes yes I understand that you shouldn't use Ice... Except the iscript I'm trying to view won't open with IceCC (I admit I haven't tried PyIce). I was told this was probably because the script is in some old format that was originally edited with Ice. If there's anything I can do to make Ice able to read this seemingly corrupted animation set, I'd love to hear about it.



None.

Jun 10 2009, 6:45 pm Heinermann Post #14

SDE, BWAPI owner, hacker.

Quote from ForTheSwarm
There's no good reason to use ICE anyways, when you have IceCC and PyICE, both of which have more functionality and don't corrupt your iscript.
GUI for modifying the scripts themselves. Graphic and sound previews.




Options
  Back to forum
Please log in to reply to this topic or to report it.
Members in this topic: None.
[03:36 pm]
Oh_Man -- a program called mapstats I think it's on here to DL
[02:39 pm]
GGmano -- so theres a limit on total triggers on around 80k?
[02:38 pm]
GGmano -- thanks for info anyway
[02:38 pm]
GGmano -- how did you found that out ohh man?
[02:15 pm]
Oh_Man -- mapstats says 80k triggers
[2022-7-02. : 9:37 pm]
GGmano -- maybe its not about the size i guess since its now above 6000 and was saved
[2022-7-02. : 9:05 pm]
GGmano -- just seems like 6000kb is an obstacle not sure
[2022-7-02. : 9:05 pm]
GGmano -- idk it could also be about the map size its like above 6k kb map wont be saved,, 6000kb of triggers no sounds im aware sounds can go beyond that size
[2022-7-02. : 8:51 pm]
GGmano -- heres link for the new release http://www.staredit.net/topic/18475/#1
[2022-7-02. : 8:51 pm]
GGmano -- i now released it after deleting triggers 3 times sadly
Please log in to shout.


Members Online: jun3hong