Staredit Network > Forums > SC1 Melee Discussion & Strategy > Topic: Help: Buildings on extended ramps
Help: Buildings on extended ramps
Oct 2 2007, 4:58 am
By: Alventenie  

Oct 2 2007, 4:58 am Alventenie Post #1



From the title, I'm trying to make a melee map that uses neutral buildings to block a larger ramp, that I extended. I can place them in the editor (that was simple), but whenever I start Starcraft and play the game on this map to test certain aspects as i go along, they never spawn in game. Currently I have them under player 12 (neutral), do I have to assign them to a player or leave them neutral, I don't know, would be great if you can answer, ty in advance.



None.

Oct 2 2007, 8:48 am BeDazed Post #2



They have to be neutral. :\
I don't see any other reason it wouldn't spawn if its on neutral.



None.

Oct 2 2007, 8:55 am Alventenie Post #3



Hmm, Ive been messing around with it for the past few hours, still detailing it and what not. I've tried them on neutral, taking them off the extended ramp to buildable ground and what not, and they still aren't spawning correctly =(. I dunno what to do now :/, I'll be done the map within a day or two and I hope this doesn't make me wait a while.

ty though for your answer, I'll keep messing with it to see what I can do.



None.

Oct 2 2007, 10:35 am who Post #4



what editor are you using?



None.

Oct 2 2007, 9:04 pm Alventenie Post #5



SCMdraft 2 ver 0.8.0



None.

Oct 6 2007, 1:00 am yenku Post #6



i think you need to use sprites.

if that doesnt work, try this:
http://www.panschk.de/mappage/newsscript/viewarticle.php?newsid=20



None.

Dec 7 2007, 8:42 pm Maian Post #7



Correct me if I'm wrong, but I thought for "Melee" game type, anything pre-placed is removed (besides critters and start locations)?

And if that's the problem, try running your game with the "Use Map Settings" game type.

EDIT: Hmm... I should pay more attention to posting dates... I was just randomly browsing the forums and came across this... oh well!



None.

Dec 7 2007, 10:22 pm yenku Post #8



Yeah, you should.

You are wrong. Player twelve units stay.



None.

Dec 9 2007, 7:59 am blacklight28 Post #9



I tried spawning Player 12 units with triggers and they wouldn't spawn for some reason. If that helps anyone answer a question.



None.

Dec 9 2007, 10:25 pm yenku Post #10



triggers don't work in melee.



None.

Dec 10 2007, 1:16 am Falkoner Post #11



Triggers don't work in melee, and preplaced units don't either, but I think disabled sprites work, you could try those, if they don't I KNOW that just plain sprites work.



None.

Dec 12 2007, 3:33 am blacklight28 Post #12



I know triggers don't work, I'm just saying something about Player 12 units, when I tried to spawn units for Player 12, it didn't work, when I changed the triggers to spawn Player 8 units it did work. I just saying taht this might be related to preplacing Player 12 units.



None.

Dec 12 2007, 11:45 am y10k Post #13



Use "sprites" -> "unit sprites" -> owner : player12 ; whatever unit building you want.



None.

Dec 13 2007, 4:55 am blacklight28 Post #14



Yea but what if he's using them to like block the way... Can you kill unit sprites?



None.

Dec 13 2007, 11:04 am y10k Post #15



They work as normal units/buildings, you can select (and order if you own) them.
There are 2 kind of sprites :
1. they only have visual, dont effect gameplay, i dont count "crash-game" as game effect-_-.
The other one is "unit sprites" i had written earlier. By the way, besides this, i dont know whats the difference between "units" and "unit sprites".

Post has been edited 1 time(s), last time on Dec 13 2007, 11:16 am by y10k.



None.

May 18 2010, 11:52 pm StarBlue Post #16



Triggers don't work on nuetral players (players 9+ and players set to nuetral) You have to use a computer player to spawn units, and have them ally you so they don't attack. Also, you can't put any nuetral units for melee, but a 0 mineral field would work nicely.



None.

Options
  Back to forum
Please log in to reply to this topic or to report it.
Members in this topic: None.
[03:05 pm]
jjf28 -- no way it's based on a game we know :P
[03:01 pm]
NudeRaider -- lol... these screenshots look oddly familiar: https://xcraft.net/colonization.html :P
[02:10 pm]
jjf28 -- :wob:
[01:11 pm]
Zycorax -- :wob:
[12:21 pm]
Riney -- :wob:
[10:45 am]
GGmano -- Lurker dosent count as Any unit?
[11:36 pm]
Zoan -- what was weird was if you give the buildings to another player the computer player keeps on building it even though it doesn'y belong to them
[11:35 pm]
Zoan -- not any unit, but I did try move buildings
[11:35 pm]
Ahli -- tried moving any unit?
[08:57 pm]
Zoan -- i just tested. you actually just cant move unfinished buildings I guess. Tried moving all players and players 9 -12, tried giving players then moving. nothing works if its unfinished, but as soon as it's finished it works.
Please log in to shout.


Members Online: Roy, KrayZee, RdeRenato, lucjan166316, MTiger156, oqowekany