Staredit Network > Forums > Modding Assistance > Topic: Give building FULL soundset
Give building FULL soundset
Jan 27 2021, 10:27 am
By: Netbek  

Jan 27 2021, 10:27 am Netbek Post #1



Buildings do not have "yes" sounds:
IMAGE 1

In PyDAT, I pasted the Marine entry onto a building to make the building become a normal unit. The "yes" sound then changes, but it is still greyed out & doesn't play in-game:
IMAGE 2

Can this be changed? I am working with GPTP, Firegraft & Python Modding Suite.




Jan 27 2021, 8:00 pm DarkenedFantasies Post #2

Roy's Secret Service

In the Units.dat file structure, there are only 106 entries for the Ready, Yes, and Annoyed sounds, so you'll need to find a way to extend those fields and have the game read them. I personally don't know how you can achieve this.




Jan 29 2021, 1:45 pm Voyager7456 Post #3

Responsible for my own happiness? I can't even be responsible for my own breakfast

Farty has been working on DatExt recently, but it's still a work in progress. I'm not sure whether expanded soundsets are implemented yet.



all i am is a contrary canary
but i'm crazy for you
i watched you cradling a tissue box
sneezing and sniffling, you were still a fox


Modding Resources: The Necromodicon [WIP] | Mod Night
My Projects: SCFC | ARAI | Excision [WIP] | SCFC2 [BETA] | Robots vs. Humans | Leviathan Wakes [BETA]


Options
  Back to forum
Please log in to reply to this topic or to report it.
Members in this topic: None.
[06:24 am]
UndeadStar -- :wob:
[12:57 am]
O)FaRTy1billion[MM] -- :wob:
[06:37 pm]
Ultraviolet -- :wob: now there's some nice :wob:s
[03:34 pm]
jjf28 -- . . . . . :wob::wob::wob::wob::wob:
[2021-4-18. : 2:51 am]
NudeRaider -- :wob::wob::wob::wob::wob:
[2021-4-18. : 2:26 am]
Ultraviolet -- :wob::wob::wob::wob::wob:
[2021-4-18. : 1:38 am]
KrayZee -- :wob: :wob: :wob: :wob: :wob: :wob: :wob:
[2021-4-18. : 1:28 am]
CaptainWill -- I saw the same...
[2021-4-17. : 11:13 pm]
Ultraviolet -- :shifty:
[2021-4-17. : 10:21 pm]
UndeadStar -- Ultraviolet
Ultraviolet shouted: :wob::wob::wob::wob::wob:
On my browser, animations are disabled by default, and somehow, those :wob: ended up not aligned, like they're doing a wave. Didn't happen with MTiger156
MTiger156 shouted: How about x6 wob? :wob: :wob: :wob: :wob: :wob: :wob:
Please log in to shout.


Members Online: Roy