Staredit Network > Forums > SC1 Mapping Tools > Topic: StarEdit won't let me save
StarEdit won't let me save
May 13 2019, 9:49 am
By: BaggyT  

May 13 2019, 9:49 am BaggyT Post #1



Hello, I've signed up to these forums because I can't find the answer anywhere else (and these forums look really good).

I still use StarEdit to make missions (I do also use scmdraft on occasion), but since the last update on Battle.net, I can't save anything. I've tried loading and altering pre-existing maps that I've downloaded - nothing. Today I started to make the first mission of a 2-player coop campaign, and it won't let me save.

Any suggestions?
(Other than "just use scmdraft" - I don't want to lose what I've done already)

Thanks.



"There is nothing enlightened about shrinking so that other people won't feel insecure around you." (Timo Cruz, Coach Carter)

May 13 2019, 10:23 am Pr0nogo Post #2



Presumably you've tried to save as a new map. This bug has been reported on the battlenet forums and it doesn't seem like there is a fix. "Just use scmdraft" is all I can advise you, especially now that blizzard's broken staredit, even if it's temporary.




May 13 2019, 2:59 pm NudeRaider Post #3

We can't explain the universe, just describe it; and we don't know whether our theories are true, we just know they're not wrong. >Harald Lesch

Quote
(Other than "just use scmdraft" - I don't want to lose what I've done already)

I'm embarrassed that I haven't tried this, but couldn't you just open, edit and save the map with Scmdraft? I know that Scmdraft can't read the SC:R MPQs but it should still be handle the maps, right?




May 13 2019, 3:24 pm Suicidal Insanity Post #4

I see you !

My assumption was he meant that the editor is still runnign with changes, and he can't get them out of the editor because it will not save. Not that ScmDraft can't open the map.

Do you know what folder staredit saves to by default, and do you have write access to that folder?




Jun 2 2019, 4:18 am TomCatFix Post #5



My girlfriend and I were having the same issue. I found a fix. I still have my old installation CDs from 1998 and the “.LOC” files were on it. What you need to do is Copy the SEditDEU.loc, SEditENU.loc, SEditESP.loc, SEditFRA.loc, SEditITA.loc, SEditPTB.loc and put them in your Starcraft folder. I’m not sure if this is an official fix, but it worked for us. I have pulled the older 1.16 version of Staredit if anyone needs it. That one still works fine.

Happy editing!



None.

Options
  Back to forum
Please log in to reply to this topic or to report it.
Members in this topic: None.
[11:36 pm]
Zoan -- what was weird was if you give the buildings to another player the computer player keeps on building it even though it doesn'y belong to them
[11:35 pm]
Zoan -- not any unit, but I did try move buildings
[11:35 pm]
Ahli -- tried moving any unit?
[08:57 pm]
Zoan -- i just tested. you actually just cant move unfinished buildings I guess. Tried moving all players and players 9 -12, tried giving players then moving. nothing works if its unfinished, but as soon as it's finished it works.
[07:54 pm]
Zoan -- Voyager7456
Voyager7456 shouted: Zoan no
;o what else do they do?
[07:49 pm]
Voyager7456 -- Zoan
Zoan shouted: so like disable all buildings but two. I mean what else is the computer player gonna do, won't they necessarily just buiild whatever they can?
no
[05:43 pm]
Zoan -- idk
[05:43 pm]
Zoan -- At least you can set the hp and build time of terran buildings so that repair never actually conteracts their hp loss while on fire..
[05:42 pm]
Zoan -- also I think you can set the hp and build time of a building so that it literally will never complete it's build, iirc.
[05:41 pm]
Zoan -- maybe if they're allied to all other players, so they don't try to do something like attack with their scv I guess.
Please log in to shout.


Members Online: Roy, oxonazob