Staredit Network > Forums > SC1 UMS Mapmaking Assistance > Topic: [SOLVED]Triggers not loading sometimes
[SOLVED]Triggers not loading sometimes
May 8 2019, 8:17 pm
By: rnDPrc  

May 8 2019, 8:17 pm rnDPrc Post #1



Hello,

I was testing stuff related to making a clock using hypers, and one thing that caught my attention was how the triggers were only loaded sometimes. At first I thought it was because I messed up some changes, or had to save them some other way (I'm using the text editor so it's kinda finnicky).

To figure that out, I put a trigger to display some text at the start and kept pressing restart map. Got the bug again, so it must be something else.

Then I thought "maybe something is wrong with some trigger", so I made a fresh map with hypers and one single trigger to display some text. Got the bug again.

Then I thought "maybe it's the hypers", so I disabled them and still got it.

If I kept restarting, triggers would load again after about 45s. Tried one more time for consistency and it did the same thing.

What I come here for is an explanation, if there's any, as to why is that happening.

Anyways, thanks for reading :)

Post has been edited 1 time(s), last time on May 14 2019, 9:46 pm by rnDPrc.



None.

May 8 2019, 8:33 pm Pr0nogo Post #2



Posting the map in question (or at least your triggers, in the menu go to Triggers and click Trigger Editor, then copy and paste into pastebin.com) would help us troubleshoot the issue.




May 8 2019, 9:35 pm rnDPrc Post #3



Quote from Pr0nogo
Posting the map in question (or at least your triggers, in the menu go to Triggers and click Trigger Editor, then copy and paste into pastebin.com) would help us troubleshoot the issue.

Here:
1st map I noticed the issue
http://www.staredit.net/sc1db/file/4390/

Triggers:
https://pastebin.com/9D6JKR80

Other map I tried afterwards:
https://pastebin.com/1zhxJr0s

I also tried setting all death counters to 0 at the beginning of the map, in case it was some lingering value that caused the problem

Cheers :)



None.

May 14 2019, 9:46 pm rnDPrc Post #4



I think the problem was having all players in the same Force, and loading the map on Single Player.

By doing that, it would just put me in one of the many available slots for humans, and only P1 had the triggers set up.



None.

Options
  Back to forum
Please log in to reply to this topic or to report it.
Members in this topic: None.
[06:51 am]
Pr0nogo -- if the person joins my server they'll be able to get all the modding info they need, since very few people mod in SEN's server afaik
[06:44 am]
Pr0nogo -- no real idea though, i haven't explored that yet
[06:44 am]
Pr0nogo -- can't be done on scr probably
[06:44 am]
Pr0nogo -- they can but you need to set them up in a specific way
[06:44 am]
jjf28 -- like not necessarily turrets/cannons, but whether any building (CC/barracks/forge) could be given a weapon
[06:42 am]
Pr0nogo -- what does 'random buildings' mean
[06:42 am]
jjf28 -- o someone was curious if you could give random buildings weapons somehow
[06:41 am]
Pr0nogo -- what did you need
[06:40 am]
jjf28 -- kay
Please log in to shout.


Members Online: Roy, lura847, NudeRaider