Staredit Network > Forums > Modding Assistance > Topic: Huncraft Genocide
Huncraft Genocide
Dec 22 2018, 8:45 pm
By: Kolokol  

Dec 22 2018, 8:45 pm Kolokol Post #1

I don't know where else to put this sooooo....
Huncraft Genocide is an unofficial expansion for Starcraft 1 (Just like Insurrection and Retribution) that takes place after the events of Episode 6. The Zerg,Terrans, and Protoss each get a new campaign and a new unit. There are,apparently, some new special buildings, music tracks, and cinematics. Genocide was made by a Hungarian company by the name of "Huncraft Interactive". Unfortunately, the game is entirely in Hungarian and there isn't any English version that I know of.
Now, I tried to download the game from ModDB and ran into a problem. I was told that Huncraft can only run with SC version 1.16 at the latest. Luckily, my installation disk happened to contain Version 1.05, so that wasn't a problem. I downloaded and then extracted the .zip files into my SC BW directory. I tried to run the game, but alas, that wasn't meant to be. When I tried to run the game, I instead got an error message saying "The Ordinal 571 could not be located in the dynamic link library C:\Users\*****\Desktop\New folder(4)\Starcraft\hcmain2.dll" (Hcmain and Hcmain2 are the dlls that are installed into the SC directory among other files)
Is there any way to fix this issue?
Second of all, assuming that there is a way to fix the ordinal error, is there a way to modify the Starcraft Campaign briefings and in-game messages to display the English translation of the Hungarian text?

Post has been edited 1 time(s), last time on Dec 22 2018, 8:52 pm by Kolokol.


Dec 23 2018, 4:18 am Pr0nogo Post #2

Use this to get a proper version of 1.16.1:

Modifying the text would require extracting and editing the maps. You can extract them with pympq (assuming it can even read the huncraft files, don't remember if it has standalone mpqs) and edit them with scmdraft.

Dec 23 2018, 8:49 am Kolokol Post #3

Quote from Pr0nogo
Use this to get a proper version of 1.16.1:
Hmm, seems as though HC requires 640*480 resolution to run.
The lowest resolution my computer's control panel allows me to drop to is 800*600, and that is not enough. Running ordinary BW worked just fine, it's Huncraft that's giving me this problem.
However, I do happen to have a virtual machine running Windows 2K, and its settings can be lowered to 640*480 and can run BW.
Going to try that now...

Post has been edited 2 time(s), last time on Dec 23 2018, 9:10 am by Kolokol.


Dec 23 2018, 10:39 pm Kolokol Post #4

Alright, I've installed Huncraft on my Win2K virtual machine and it ran just fine.
Next, I downloaded PyMPQ. On Windows 10, it worked just fine. On the VM, not so much. When I tried to run PyMPQ on the virtual machine, I got this error:
How do I deal with that?
P.S.: Huncraft does have standalone MPQs

Post has been edited 1 time(s), last time on Dec 24 2018, 2:06 am by Kolokol.


Dec 24 2018, 12:49 am Pr0nogo Post #5

Just extract them on win10, edit the files, repack, and move them to your VM afterwards.

Jan 31 2019, 1:50 am Kolokol Post #6

So I have a few more things that I want to clarify.
Firstly, the extensions for the campaign scenario files are .chk, which is recognized by SCMDraft but not by Hunedit. I want to use Hunedit to dig around in the maps in case there are triggers or units that SCMDraft doesn't recognize (Like creating Huncraft units, or there are special Huncraft-only buildings on the map).
OK, I changed the file extension to .hcx and could use Hunedit now. However, I wonder whether changing the file extension alone could mess up with the map somehow. Is that possible?

Secondly, sometimes I get an "Invalid Unit Placement. Invalidly placed units have been deleted" error when opening a Huncraft map with Hunedit. Other than that, I can work with the map just fine. Could it interfere with playing the map? How can I fix it without messing anything else up?

Thirdly, how do I change the screen that's displayed before the map is run?

And finally: I've seen on Youtube playthroughs of Huncraft that there are some custom unit portraits as well.
Is there a risk that the map editor won't recognize them (And either crash or just delete the triggers associated with them) when I open a map?How can this be avoided?


Jan 31 2019, 4:11 am Pr0nogo Post #7

I'm not aware of any issues regarding file extensions. In fact, you could probably edit the maps in SCMDraft (with them saved as chk files), and then resave them as hcx files. However the best bet for editing (which will resolve the second issue, hopefully) is actually to create a new profile in SCMDraft and load the modded MPQs from Huncraft. I would start by adding the standalone Huncraft MPQs referenced in earlier posts, and if that isn't enough you can extract all modded files from them and repack them into a single MPQ.

For the title cards/screens, the text is controlled by plain text files (e.g. rez\estt01x.txt). Maybe one of the Huncraft mpqs has some of them you can edit, if you were trying to translate what they said. The images are pcx files located in the glue\ directory. You can open the mod for Resonance to see how Church modified the files if you need more examples than Blizzard's own (and whatever is in the Huncraft MPQs). Note that these rules apply to the base game. Not sure if Huncraft modified the rules for these in any way (I wouldn't expect that they have).

Portraits aren't directly referenced by the editor. The way trigger actions work is that they display the portrait file linked in units.dat. So if you were to change the portrait of the Terran Command Center unit entry from the adjutant to the zealot, and then in the briefing showed a portrait of a Command Center, it would show the zealot portrait.

Post has been edited 1 time(s), last time on Jan 31 2019, 4:16 am by Pr0nogo.

Feb 2 2019, 8:51 am Kolokol Post #8

I seem to be having a rather peculiar problem with SCMDraft. It seems as though it simply does not "see" any new MPQ files that are linked to a profile. I tried to create a new profile and add the Huncraft MPQ file to it. Then I saved, clicked "Apply settings", and restarted SCMDraft. I then tried creating a test map to see if the linking was successful. Nothing happened. There were no special HC units or buildings, nada. I checked the settings and it displayed that the HC MPQ file was in fact among the data files for the profile. Yet it seems as though SCMDraft does not aknowledge that in any other way.

Just for funsies, I removed the standard SC MPQs from the new profile, saved, clicked the "Apply" button, and restarted. SCMdraft's map editor failed to start, as I thought it would. I then added the same MPQ files to the profile, saved, applied, and restarted. I checked the profile settings and saw that the standard MPQs were now added to the profile. However, the editor failed to start despite the fact that I re-linked the files.

Simply put, it seems that SCMDraft doesn't recognize when another MPQ gets added to a profile. Any ideas on how to fix that?

Post has been edited 1 time(s), last time on Feb 2 2019, 8:58 am by Kolokol.


Feb 2 2019, 11:51 am Pr0nogo Post #9

I haven't had that issue before. I'd create a map in hunedit and try opening it with scmdraft (with your huncraft mpqs loaded), and compare the results. If you've already done that, I'd PM SuicidalInsanity (maker of SCMDraft) and see if he has any ideas.

Feb 2 2019, 9:30 pm Kolokol Post #10

I tried what you suggested, and I think I found something interesting.
I created a test map in Hunedit and plopped some units and buildings down. I then saved the map and opened it with SCMDraft, both with and without the MPQ loaded in. In both cases, instead of seeing the HC units when I opened up the map, I saw the normal SC units. For instance, what was the Terran Phantom (HC Unit) showed up as a Kerrigan Ghost in SCMDraft. This also worked in reverse: When I placed a Kerrigan Ghost in a map using SCMDraft, it showed up as the Terran Phantom in Hunedit. And yes, there is no Kerrigan Ghost hero in Hunedit. It's as if the normal Kerrigan and the Phantom unit use the same slot and Hunedit just recognizes it differently.
So, could I just edit Huncraft maps without having to do any additional tinkering with SCMDraft? Would this mess up map triggers and unit properties in HC if I do ( I don't think so, but I just want to be sure)?


Feb 2 2019, 10:46 pm Pr0nogo Post #11

Well you can't yet add brand new units, you have to replace existing units. So the Kerrigan unit ID is replaced with the phantom, in this case. Only potential issues could be the units not having proper collision but that's easy to test in game.

Feb 3 2019, 1:33 am Kolokol Post #12

I tried to run my little test map in single player on UMS to test unit collision. However, I get an error message saying "You must have at least 1 computer opponent" (Well, it's Hungarian equivalent,actually) when I try to run the map, despite the fact that only one player slot is human and all the rest are computers and are in separate force slots.
In normal Brood War, I would just run a map in multiplayer to test it. But multiplayer doesn't work in HC. What's the matter here?


Feb 3 2019, 1:44 am Pr0nogo Post #13

Did you place start locations in the map for the computer players, and set the game mode to Use Map Settings?

Feb 3 2019, 1:48 am Kolokol Post #14

Yes, I placed starter locations for all players and set the mode to UMS.


Feb 3 2019, 2:06 am Pr0nogo Post #15

I'd try resaving the map as an scx and see what happens. No other ideas off the top of my head.

Feb 3 2019, 2:15 am Kolokol Post #16

I tried saving the map as a .scx, which resulted in it not even showing up when I searched for maps in my maps folder. Changing the file extension back to .hcx caused it to show up once more, but the problem is still present.


Feb 3 2019, 2:43 am Pr0nogo Post #17

Ok, sounds like Huncraft itself is messing stuff up. I'd recommend extracting all files from the various huncraft MPQs (you'll need WinMPQ if you intend to extract sounds), creating one single MPQ and importing all files into it. Then, open this master MPQ with Firegraft, create a new exe and save it, and when it asks you if you want to import an MPQ, say yes and select your master. This (should) port all changes that aren't related to unit permissions and button sets, since those were presumably grafted elsewhere. You'll have to recreate those manually later, but theoretically you'll be able to open scx files fine with this mod.

If this works and you can run your maps as scx, what you'll then need to do is find all the new abilities/upgrades/units etc that exist, and manually create additional button sets and apply permissions for training the unit or researching the upgrade. Using the phantom as an example, I assume it trains at the starport, so you'd want to go to the starport's button set and add a button that trains Sarah Kerrigans, and then go into Dat Requirements, find the Sarah Kerrigan entry, and make it look identical to the wraith entry (or if it needs a control tower, the dropship entry would work). You'll need to do this for all others and I'm not familiar with Huncraft's specifications. Since this is extra overhead for you, I'd make sure the exe/master MPQ works with your test map before doing any of this. Then you can test the campaign missions to make sure your button set changes went through and all functionality is preserved.

I still don't see why Huncraft would fail to boot a test map in UMS, so maybe this isn't related to the issue, but it's a step I still think you should take since installing a campaign the way Huncraft forces you too is very awkward and presumably wouldn't even be compatible with your conversion/translation anyways.

Feb 3 2019, 2:49 am Kolokol Post #18

Actually, nevermind. I have two copies of the map for backup purposes. I've set the other players to be computers in only one version and realized that the path for opening the map in SCMDraft did not lead to the version that I was trying to launch. In other words, I was editing the wrong version of the map :lol: .
Anyways, unit collisions seem to be working fine.
Also, what is the directory for advisor messages (Like "Base is under attack") and unit quotes?


Feb 3 2019, 2:50 am Pr0nogo Post #19


Feb 6 2019, 9:29 pm Kolokol Post #20

Hmmm. If I wanted to add a text screen where there wasn't one previously, how would I go about it?


  Back to forum
Please log in to reply to this topic or to report it.
Members in this topic: None.
[08:53 pm]
TheHappy115 -- such as things like Center View work differently on online play (instant on online while single moves the screen slowly and pauses)
[08:52 pm]
TheHappy115 -- I had played spellsword on Remastered roughly 3 - 4 years and it worked fine so not sure why it doesn't work now. Big Rips. I know there is some form of trigger that detects whether its online or not but I imagine it has something to due with latency
[2022-5-23. : 10:53 pm]
Butch -- prob some weird character on a string somewhere or something dumb like that
[2022-5-23. : 9:50 pm]
Ultraviolet -- It's weird indeed, not really sure what is so special about Spellsword that causes it to react differently on Remastered, usually EUDs are the cause of things like that
[2022-5-23. : 5:35 pm]
Zoan -- I haven't played in like 2 years so maybe something changed I don't know about
[2022-5-23. : 5:35 pm]
Zoan -- No-Name-Needed-II
No-Name-Needed-II shouted: Zoan No idea if anything changed.. I've made several maps that push TMOANC to the limit and they are still working.. 3 causes of it I've narrowed down are -Too many islands which some terrain on certain tilesets can create micro islands on cliff edges with basic isometric.. -Too many changes in elevation from high to mid to low ground.. -And too many tiles from certain doodads that block tank fire..
Any clue as to why a map which would previously work fine on past patches would now suddenly not work on the current remastered patch?
[2022-5-23. : 5:34 pm]
Zoan -- I'll try Butch's suggestion of running in 32-bit, maybe that will fix it?
[2022-5-23. : 5:34 pm]
Zoan -- Oh_Man
Oh_Man shouted: Did martiss' link not work?
It crashes as it does when you use EUD's incorrectly - like it closes starcraft and has the error window pop up with a ticket to send to Blizzard. I know it's not EUDs though since obviously spellsword doesn't use any, so IDK what it is.
[2022-5-23. : 3:19 pm]
No-Name-Needed-II -- Zoan No idea if anything changed.. I've made several maps that push TMOANC to the limit and they are still working.. 3 causes of it I've narrowed down are -Too many islands which some terrain on certain tilesets can create micro islands on cliff edges with basic isometric.. -Too many changes in elevation from high to mid to low ground.. -And too many tiles from certain doodads that block tank fire..
[2022-5-23. : 12:21 am]
Oh_Man -- Wat precisely is wrong with spellsword now?
Please log in to shout.

Members Online: Roy, Oh_Man