Staredit Network > Forums > SC1 UMS Mapmaking Assistance > Topic: EUD Editor "TriggerEditor.eps" error
EUD Editor "TriggerEditor.eps" error
Oct 5 2018, 12:38 pm
By: TurtleMountain  

Oct 5 2018, 12:38 pm TurtleMountain Post #1



Whenever I click Insert I get this error or some variation of it,

https://i.imgur.com/GkfWOQG.png

First time messing with EUD Editor so I dunno if im doing something wrong or what, just trying to change a unit's weapon.

Post has been edited 1 time(s), last time on Oct 5 2018, 12:43 pm by TurtleMountain.



None.

Oct 5 2018, 1:07 pm MTiger156 Post #2



Just a random stab at the error message:
Perhaps missing something called "cputf8.pyc". Looks like it should exist at (eudDraft directory)\lib\eudplib\eudlib\stringf




Oct 5 2018, 1:17 pm Roy Post #3

An artist's depiction of an Extended Unit Death

Judging from your file paths, I'm guessing you cloned the git repo for euddraft instead of downloading a zipped release. Maybe you're not using the right version of euddraft?

Link to 0.8.2.4, from the EUD Editor 2 post: https://github.com/phu54321/euddraft/blob/master/latest/euddraft0.8.2.4.zip

All versions: https://github.com/phu54321/euddraft/tree/master/latest

I quickly tinkered around in EUD Editor 2 pointing at version 0.8.2.6 of euddraft and was able to change a Marine's weapon to a Siege Tank's.




Oct 5 2018, 1:30 pm TurtleMountain Post #4



Quote from MTiger156
Just a random stab at the error message:
Perhaps missing something called "cputf8.pyc". Looks like it should exist at (eudDraft directory)\lib\eudplib\eudlib\stringf

Quote from Roy
Judging from your file paths, I'm guessing you cloned the git repo for euddraft instead of downloading a zipped release. Maybe you're not using the right version of euddraft?

Link to 0.8.2.4, from the EUD Editor 2 post: https://github.com/phu54321/euddraft/blob/master/latest/euddraft0.8.2.4.zip

All versions: https://github.com/phu54321/euddraft/tree/master/latest

I quickly tinkered around in EUD Editor 2 pointing at version 0.8.2.6 of euddraft and was able to change a Marine's weapon to a Siege Tank's.

Thanks for the answers, and yeah you're right Roy. It's working now, I feel so stupid xD.



None.

Options
  Back to forum
Please log in to reply to this topic or to report it.
Members in this topic: None.
[09:53 am]
Suicidal Insanity -- Were you able to enter arbitrary AIScript IDs?
[09:53 am]
Suicidal Insanity -- Its not that important, text trigedit apparently parses one of the files to verify AIScript IDs, but I dont think the code is used
[09:52 am]
Suicidal Insanity -- I know that. But if AIScript has 'multiplayer-simple' does BWScript have 'multiplayer-simple-ex' or 'multiplayr-simple'?
[05:19 am]
Pr0nogo -- aiscript has vanilla AI, bwscript has expansion AI
[11:38 pm]
Suicidal Insanity -- Hmm, it doesn't store string names does it?
[11:27 pm]
Suicidal Insanity -- Does the bwscript.bin file just replace the aiscript.bin file with AIs that use BW units, or is the union of both files used by the game?
[10:15 pm]
Suicidal Insanity -- Cool, I have french unit names in my unit tree
[09:03 pm]
Suicidal Insanity -- Either that or the installer wasn't really korean
[09:02 pm]
Suicidal Insanity -- Hmm, I had an old SC 1.15 anthology installer lying around for korean starcraft, but the unit names and so on don't seem to be localized?
[08:05 pm]
Suicidal Insanity -- And there are way too many threads complaining about staredit not working - why aren't they using scmdraft ;(
Please log in to shout.


Members Online: Roy, matildaelynch, Marcouse3, datura