Staredit Network > Forums > General StarCraft > Topic: Starcraft Classic Installer & Downgrader
Starcraft Classic Installer & Downgrader
Jun 17 2018, 3:41 am
By: O)FaRTy1billion[MM]  

Jun 23 2019, 7:52 pm DarkenedFantasies Post #21

Roy's Secret Service

I have another workaround, but before doing so, make sure the implicated processes aren't running.
1) Open task manager and in the processes tab, click "Show processes from all users" and kill these if found:
dllhost.exe with "/Processid:{F9717507-6651-4EDB-BFF7-AE615179BCCF}" in the command line column
rundll32.exe *32 with "gameux.dll,GameUXShim" in the command line column

OR restart computer, whichever is more convenient for you.

This is for 64-bit Windows. If using 32-bit, syswow64 = system32
2) Run command prompt as admin and type:
/f c:\windows\syswow64\gameux.dll

After entering the line, you should get SUCCESS. Take note of the quoted username given in the line.
Now type:
cacls c:\windows\syswow64\gameux.dll /E /P (USER):F

where (USER) is everything given in quotes in the SUCCESS message.

After entering the line, you should get processed file. Now type:
ren c:\windows\syswow64\gameux.dll _gameux.dll

After entering the line, there won't be any messages, but gameux.dll should be renamed and hopefully SC will work now. If that still doesn't work, try repeating the process for system32 instead of syswow64.




Jun 24 2019, 5:59 pm Pandut Post #22

I'm just a fish

I'm running on 64-bit, I'm getting an 'unrecognized command' error on the '/f' line. Is it supposed to be /f:on or /f:off?



None.

Jun 24 2019, 8:30 pm DarkenedFantasies Post #23

Roy's Secret Service

Apologies, I've mistakenly left out the command for that line. Should be:
takeown /f c:\windows\syswow64\gameux.dll





Jun 24 2019, 9:18 pm Pandut Post #24

I'm just a fish

Bah. Getting an 'Access is Denied' on the last line. On both syswow64 and system32 attempts. Even though I ran cmd as admin. Did some quick googling and apparently windows is extremely overprotective of gameux.dll for some reason even though it's an obsolete file nowadays.

Post has been edited 1 time(s), last time on Jun 24 2019, 9:27 pm by Pandut.



None.

Jun 24 2019, 11:23 pm DarkenedFantasies Post #25

Roy's Secret Service

Does %username%:F work instead?




Jun 25 2019, 6:40 pm Pandut Post #26

I'm just a fish

Negatory. Should've noted that I'm getting a 'No mapping between account names and security IDs was done' message after doing the cacls command, on both (USER) and %username% attempts.



None.

Jun 25 2019, 11:56 pm DarkenedFantasies Post #27

Roy's Secret Service

Other than right-clicking on gameux.dll and trying to change the permissions directly through the properties screen as a last resort, I don't really know how to help you at this point. No clue why your Win7 is giving you so much trouble.




Nov 13 2019, 6:00 pm Zincoshine Post #28



The patcher does not work at all, everytime I attempt to run it I get an access_violation exception

Edit: nevermind, the problem was UAC. Fixed the problem by disabling the damn thing.

Edit2: It appears that Stardraft patches do not open anymore no matter what version is used. Strange, using stardraft patches with starcraft version 1.07 used to work fine on windows 7.

Post has been edited 2 time(s), last time on Nov 13 2019, 6:09 pm by Zincoshine.



None.

Options
  Back to forum
Please log in to reply to this topic or to report it.
Members in this topic: None.
[01:41 am]
Ultraviolet -- :wob:
[09:59 pm]
Apos -- :wob:
[08:51 pm]
Andrea Rosa -- jjf28
jjf28 shouted: riskiest click
LOL
[08:17 pm]
jjf28 -- riskiest click
[05:01 pm]
NudeRaider -- Andrea Rosa gross!
[04:51 pm]
Andrea Rosa -- Heck, being a "scatman" was completely fine before Internet porn took a bad turn.
[03:04 pm]
NudeRaider -- we only enjoy dragon dildo here, no scat fetish allowed.
[02:47 pm]
Vrael -- eww
[02:19 pm]
Andrea Rosa -- Ski-bi dibby dib yo da dub dub, Yo da dub dub, I'M THE SCATMAN!
Please log in to shout.


Members Online: Ultraviolet, Roy, DarkenedFantasies