Aug 10 2017, 6:15 pm
By: Neiv
Pages: < 1 6 7 8

Dec 29 2021, 12:43 pm wwwkookcom Post #141

Thank you Samase 0.7.31 used.

Samase MOD starcraft remastered v Execution error.... T.T

Please Samase bug fix update.

Thank You Neiv

2022 Happy New Year~!!


Dec 31 2021, 7:57 pm Neiv Post #142

Okay, updated to work with the current patch: Download


Jan 12 2022, 7:33 am Erlo Post #143

Is there any prerequisites I need to have installed to run Samase?
I've been trying to run samase version 0.7.42, but I get the error "Couldn't extract DLL: Access is denied. (os error 5)". It seems to be when starcraft is about to be launched, since I can successfully run samamse with the --pack parameter but then I get the same error when trying to run the self executing exe created.

Oh, and if it is relevant, I have StarCraft remastered version

Thank you for this awesome looking tool!


Jan 13 2022, 12:52 am Neiv Post #144

Huh, it fails to write a file to a temp directory. Most likely to "%TEMP%\samase", not sure why that would ever fail.

Anyway, here's an update that reports the exact path that is failing, so try it and see if you see something on your system that would prevent accessing that path. May be antivirus software that doesn't trust the exe?


In other news, this update also has support for locale paths. That is, `Locales\enUS\Assets\rez\stat_txt.json` now gets priority over plain `rez\stat_txt.json` if the game is currently in English.

You can still use the non-locale paths in case you only want to support one language, or if there is a specific language that should be "preferred default" for languages that you don't have localized files for.

Samase will always try to load a file for any locale if it exists, instead of loading default Blizzard files. The full file lookup order is now:

1) Currently active language `Locales\___\Assets\PATH`
2) Plain `PATH`
3) Any other language `Locales\___\Assets\PATH` in order enUS, deDE, esES, esMX, frFR, itIT, jaJP, koKR, NOLA, plPL, ptBR, ruRU, zhCN, zhTW
4) If the path starts with `HD2` or `SD`, check steps 1-3 without the `HD2`/`SD` prefix
5) Load default Blizzard file


Jan 13 2022, 7:44 am Erlo Post #145

Thanks for the quick response.

It was indeed my antivirus that blocked the dll in the Temp folder.

It works great now, thanks!


Feb 3 2022, 1:35 am RexyRex Post #146

fucc i been using this for a while and its so good

i cant get it to work anymore tho

the log says its working

[2022-02-02][16:56:29.401][src\][INFO] Loading custom tileset/
[2022-02-02][16:56:29.402][src\][INFO] Loading custom tileset/

but the modded that I've been using for months that used to work is just not anymore.
my creep tiles (the first few tiles in the set) are loading up as default instead of the solid R / G / B colors I set

any ideas family


Feb 3 2022, 9:53 am Nekron Post #147

probably hard to know whats up without the exe/files/anything more

Feb 8 2022, 8:11 am RexyRex Post #148


samase-0.8.2.exe with the first couple creep tiles set to solid R G B

and this green screen map to test:

Hits: 0 Size: 22.4kb


Feb 8 2022, 8:50 am RexyRex Post #149

Nevermind i'm dumb

it was working the entire time



May 15 2022, 4:22 am hexamon Post #150

Its been a while since I tried to put together a mod for SC.. like back to the original game. I dropped my old moded DAT files into a directory and ran samase-0.8.2. The log files says the DAT files are loaded... but there are no changes to unit/weapons/upgrades, etc in the game. I'm running version or SCR. Looking for some suggestions :-/


May 15 2022, 7:55 am Nekron Post #151

Noone will be able to help without more details, can you share the mod? Are you actually launching the modded executable? If the DAT files are very old maybe they're made with something that wouldn't work now

May 15 2022, 1:38 pm hexamon Post #152

I tried running SC by launching it via samase and I also tried creating an executable. Neither approaches worked. I am running SC via Lutris on an Ubuntu box. Here are the exe and mod files.

I was able to use PyMS to decompile DAT files. Next I'm going to try recompiling them and see if that changes anything.

Thanks :)


May 15 2022, 7:21 pm Nekron Post #153

Alright lmao I would have no idea if anything on Linux works or how to make it work, sorry

Pages: < 1 6 7 8
  Back to forum
Please log in to reply to this topic or to report it.
Members in this topic: None.
[03:53 am]
jjf28 -- memes
[2023-3-26. : 5:11 pm]
KroznadeSC -- Didn't see the color selection on the left XD
[2023-3-26. : 5:10 pm]
KroznadeSC -- hehe, I managed to on XD
[2023-3-26. : 3:21 pm]
Vrael -- <div class="TakeOverAsAdmin" class="threeturtlesinastraightjacket" class="Boppin"> Hi Guys! Nothing inconspicuous here!</element>
[2023-3-26. : 6:54 am]
NudeRaider -- KroznadeSC
KroznadeSC shouted: oh my god sorry having problems typing
you mean having problems cheating your way into a shoutbox color :P
[2023-3-26. : 4:56 am]
Dem0n -- meme
[2023-3-26. : 3:34 am]
KroznadeSC -- :wob:
[2023-3-26. : 2:45 am]
O)FaRTy1billion[MM] -- i forgot this was a thing
[2023-3-26. : 2:44 am]
O)FaRTy1billion[MM] -- ya
[2023-3-25. : 11:56 pm]
KroznadeSC -- oh my god sorry having problems typing
Please log in to shout.

Members Online: Salamano, Roy, jjf28