Staredit Network > Forums > SC1 Mapping Tools > Topic: scmdraft - 0.9.0 info + nightly download (Post small feature req
scmdraft - 0.9.0 info + nightly download (Post small feature req
Apr 9 2017, 9:27 am
By: Suicidal Insanity
Pages: < 1 36 37 38 39 4046 >
 

Aug 15 2018, 11:59 am Suicidal Insanity Post #741

I see you !

I meant if you set every player to red in scmdraft, and then reload the map, is every player still set to red in scmdraft? If that is the case then it is unlikely to be saved incorrectly in the map file.




Aug 15 2018, 4:53 pm MTiger156 Post #742



I'm getting enormous delays when loading or saving maps (SCMD freezes for 6+ seconds). Output console displays lots of errors while doing so.


Post has been edited 1 time(s), last time on Aug 15 2018, 6:13 pm by MTiger156.




Aug 15 2018, 7:20 pm Suicidal Insanity Post #743

I see you !

Do you happen to have lots of unburrowed zerg ground units on the map?




Aug 15 2018, 7:55 pm MTiger156 Post #744



The freezing just needed a CPU restart. I did have ~100 zerg on the map, but burrowing them appears not to solve the output errors. Thankfully, it does not affect the mapping process.




Aug 15 2018, 9:47 pm Suicidal Insanity Post #745

I see you !

The warning is a sideeffect of loading unburrowed zerg units - after creating the graphics it tries to unburrow them and the shadows aren't hidden and then don't have a unburrow animation. I have a rough idea of how to avoid them but haven't gotten around to verifying yet.




Aug 21 2018, 11:05 am Lanthanide Post #746



In recent versions of Scmdraft - I'm running 0.9.05, you can no longer place a terran building + its addon, and then move the add-on to an arbitrary place on the map and have the add-on still connected and operating. This was achieved by selecting the add-on and then using ctrl or shift + arrow keys to move the addon around the map away from the parent building.

You used to be able to do this eg with a comsat station or a nuclear silo, where you could move the comsat very far away from the CC, and still be able to cast scanner sweep, or if it was a nuclear silo, could still construct a nuclear missile.

Strictly speaking this might have been a bug in older versions of scmdraft, but since SC actually works fine with this, it is just yet another quirk / bug in SC itself, and so we should be able to make use of this in scmdraft.



None.

Aug 21 2018, 12:11 pm Suicidal Insanity Post #747

I see you !

A while ago all functions that changed a unit (so X/Y, lift-off and land, unit type, owner, etc) were simplified to use a shared set of functions. That probably means that moving now triggers the 'IsValidAddon' check to update the graphics and so on.

I can put that on the idea list. Unfortunately the connection is SC is always two way. (I once tried to daisy chain nydus canals, doesn't work. I'm assuming addons in the same thing)




Aug 21 2018, 11:25 pm Lanthanide Post #748



It's a regression in functionality though. IMO it's a bug, not an 'idea'.



None.

Aug 22 2018, 8:32 pm MTiger156 Post #749



Small annoyance, but the mini-map does not display properly when opening maps (about 80% of the time), though it remains functional. I don't see any output console errors related to it.





Aug 22 2018, 10:20 pm Suicidal Insanity Post #750

I see you !

which build? official release or alpha? I remember there being one alpha with a similar bug but it should have been fixed for a while.

Post has been edited 1 time(s), last time on Aug 22 2018, 10:29 pm by Suicidal Insanity.




Aug 22 2018, 10:39 pm MTiger156 Post #751



I'm using the most recent (8/20) build.




Aug 24 2018, 12:52 am Ultraviolet Post #752



I've also been experiencing this issue. Sometimes have to open the map several times to get the minimap to display.




Aug 24 2018, 4:25 am DarkenedFantasies Post #753

Roy's Secret Service

I have this issue as well. Dragging the panel's side (resizing it) fixes the minimap display for me.




Aug 24 2018, 9:08 am Suicidal Insanity Post #754

I see you !

Will take a look this weekend. In the future please report those things ASAP, so they get fixed faster. =)




Aug 24 2018, 6:03 pm DarkenedFantasies Post #755

Roy's Secret Service

Sorry, I thought it was just me since that update was out for a while now and nobody else reported what seemed to me like a very obvious bug, until now. :( And the simple remedy made it a non-issue to me.

While we're at it, enabling AI Town Locations overlay on a map that doesn't have any (probably most non-melee UMS maps) causes a crash.




Aug 24 2018, 11:47 pm Suicidal Insanity Post #756

I see you !

Can you PM or email me a map that does that? I can't trigger a crash with the maps I've tested. And perhaps include the crash dump?

E: nevermind, reproduced it with a map with zero resource nodes.

Post has been edited 1 time(s), last time on Aug 25 2018, 9:59 am by Suicidal Insanity.




Aug 25 2018, 2:00 am Pr0nogo Post #757



All start locs are resareas even if there are no resources associated with them. Not sure if scmd reflects this logic with the preview. And it should definitely be called "Show AI Resareas" instead of towns, because "town" means something completely different in AIspeak.

Haven't seen any problems with the function in the latest build, seems accurate so far. Great work!




Aug 25 2018, 9:44 am iDoodler Post #758



If it exists I'm not aware of it, but I would suggest being able to change the index/order of locations. I heavily consider remaking my maps completely once they are done, just to reorder locations.

I thought I saw somewhere this was already implemented, but I've been trying for the last half an hour to no avail. I think having an input box in the properties of the location as well as being able to drag and drop in the GUI on the left would be sick. Please aid my OCD mind. :hurr:

On a side note, if 2 locations had the same index would they be used in tandem or just cause a crash? Or not even possible at all? Just a thought... Any slim chance for a revolution of location shapes is worth it :)



Noob Map Maker

Aug 25 2018, 10:02 am Suicidal Insanity Post #759

I see you !

iDoodler: The index isn't a real location property, it is generated from the stored order. So the first stored location gets index 0, second one gets index 1, etc. So it isn't possible to have two locations have the same index, because then they would share the same data in the file.

Reordering locations would break every trigger that uses the location because the triggers refer to locations via index and that would change.


E: Minimap issue is also fixed - I had only fixed it in the Unicode branch but the change hadn't been merged to the other branches yet.

Post has been edited 1 time(s), last time on Aug 25 2018, 11:24 am by Suicidal Insanity.




Aug 25 2018, 12:23 pm iDoodler Post #760



Reordering locations would break every trigger that uses the location because the triggers refer to locations via index and that would change.

If this is true, why don't triggers mess up while importing them via the text trigger editor?
Through my limited knowledge wouldn't you be able to work around it by right as you reorder the locations, you basically run the process that the trigger editor uses to error check/import the triggers?

EDIT: I could see this having an issue when there are multiple locations have the same name though...



Noob Map Maker

Options
Pages: < 1 36 37 38 39 4046 >
  Back to forum
Please log in to reply to this topic or to report it.
Members in this topic: None.
[10:00 am]
KrayZee -- :0
[09:36 am]
Suicidal Insanity -- They just have a discord for posting even more memes than they post here ;(
[08:20 am]
SiKiN -- You guys have a testing group for maps? Or a discord?
[06:34 am]
MasterJohnny -- Zoan
Zoan shouted: guys im going to China in 2 days
Bring dust mask things and a mosquitoes net. If anyone asks nothing happened on June 4 1984.
[06:34 am]
O)FaRTy1billion[MM] -- NudeRaider
NudeRaider shouted: FaRTy1billion I'm wondering: Does extended anything (like place extended units for supply) count as euds (i'd guess no)? Do these overflows still work?
I'm pretty sure all extended units and extended players were fixed
[06:14 am]
Pr0nogo -- I mean I get people not wanting to put in the work, it's not easy, but then they'll say as much without people whining in the shoutbox about my posts
[06:14 am]
Pr0nogo -- in this case quality is my priority, so... yeah, you should share that LMAO
[06:13 am]
Pr0nogo -- I was just snarking at dem0n with that response anyways, but i don't think you can argue that deliberately handicapping your work within sc's engine means you don't care as much about quality
[06:13 am]
Pr0nogo -- NudeRaider
NudeRaider shouted: Pr0nogo still turning a blind eye for the reason map making is more widespread than modding just insults your intelligence. It's an almost autistic view to demand that everyone shares your priorities.
i am autistic
[05:58 am]
NudeRaider -- Pr0nogo
Pr0nogo shouted: Dem0n people should probably stop just making maps
still turning a blind eye for the reason map making is more widespread than modding just insults your intelligence. It's an almost autistic view to demand that everyone shares your priorities.
Please log in to shout.


Members Online: Roy, Brusilov, Nekron, sadus111564, jun3hong