Staredit Network > Forums > Modding Assistance > Topic: Running a multiplayer mod
Running a multiplayer mod
Aug 14 2016, 3:40 pm
By: Zoko-TkZ  

Aug 14 2016, 3:40 pm Zoko-TkZ Post #1

I'm trying to see how I can get my mod working with multiplayer. I've been compiling it using firegraft (mpqdraft isn't working for me for some reason) and trying to play it through Iccup. I'm able to create and run a game just fine but when someone running the mod tries to join my game (or when I try to join theirs) they get a message about my latency being too high. We are able to join other people's games with the mod on and we can join each other's games with the mod off. Because of this I don't think it has anything to do with latency but I have no idea what it might be. Does anyone know what can cause an issue like this? What are the ways people usually go about running mods for multiplayer?


Aug 14 2016, 4:07 pm Dem0n Post #2

ᕕ( ᐛ )ᕗ

When I tried playing maps with people using EUD Enabler, we had to make sure that we all had "LAN Lat" enabled, or else it wouldn't work right. Maybe that's the issue? I'm not really sure.

Memes gather, and now my watch begins. It shall not end until my death. I shall take no wife, hold no lands, father no children. I shall wear no crowns and win no glory. I shall live and die at my post. I am the sword in the darkness. I am the memer on the walls. I am the shield that guards the realms of memes. I pledge my life and honor to the Meme's Watch, for this meme and all the memes to come.

Aug 14 2016, 7:09 pm Sand Wraith Post #3


Try using something like Hamachi that can simulate a LAN and then connecting by UDP LAN to each other.

Aug 14 2016, 9:38 pm noobscrub Post #4

le LITERALLY me when im ex dee while driving face xdddd

What mod are you trying to play?

I play Burning Ground on Garena and works btw.


Aug 15 2016, 10:47 pm Zoko-TkZ Post #5

Thanks for the suggestions, I won't get the chance to try then until tomorrow night so I can't verify that anything works yet. I'm also wondering if anyone has played any mods over Iccup, and if so what format the mod was in and what they needed to do to get it to run.

@Sandwraith I figured hamachi could work, I'm hoping though that I can get it to run on something with a built-in client so that it might be easier to reach out to people who already use it to play starcraft and might be interested in the mod.

@scrub I'm attempting to create my own mod. Haven't tried Garena but its worth a shot, I'll take a look at Burning Ground to see what format it is in exactly.

The way I'm trying to run the mod is by saving as from Firegraft to my Iccup folder as StarCraft.exe (the original .exe is namechanged) and selecting the original through the prompt that comes up. For some reason saving the file as anything other than StarCraft.exe causes the game to use the .dat files from the original version.

UPDATE: got it running with the iccup launcher (not mca64launcher) by disabling version check and having lan lat enabled. For some reason the first time I hosted the issue came up again but not subsequent times. Still no idea why it was happening but I guess I'll call this a win.

Post has been edited 1 time(s), last time on Aug 17 2016, 2:30 am by Zoko-TkZ.


  Back to forum
Please log in to reply to this topic or to report it.
Members in this topic: None.
[09:03 pm]
Ashamed -- On a happy note... I managed to stream a 50gb 4k file via plex ( While encoding ) This pushes my threads to the max though ha...
[09:03 pm]
Ashamed -- Mini Moose 2707
Mini Moose 2707 shouted: Ashamed mad
yeah wth am I going to do with 16 cores and 32gbs of ram on a single host lol
[09:02 pm]
ihjel -- theskinsurf
theskinsurf shouted: it would be very weird to start a map and not touch the intraforce allies and have them lose alliance/vision somehow, never happened to me
Happens when humans and computers are mixed in a force.
[08:51 pm]
Mini Moose 2707 -- Ashamed
Ashamed shouted: all the matx boards blow :(
[08:30 pm]
Ashamed -- all the matx boards blow :(
[08:29 pm]
Ashamed -- My new Mobo doesn't support visualization :( I am hoping it will get a bios update. Dumb bought 16 core processor and 32gbs of ram and I can't even virtulize ha. W00t new Hardware!
[07:10 pm]
Ashamed -- ><
[05:28 pm]
NudeRaider -- jjf28
jjf28 shouted: NudeRaider way down on my priority list tbh
FaRTy1billion shouted: NudeRaider never had these problems in the first place :wob:
which is probably why they fixed it :rolleyes: (others suffer from it) Also while I also have workarounds for it I appreciate native support.
[05:18 pm]
theskinsurf -- it would be very weird to start a map and not touch the intraforce allies and have them lose alliance/vision somehow, never happened to me
[05:15 pm]
theskinsurf -- cross-force allies won't start with vision or alliance, intraforce allies should
Please log in to shout.

Members Online: Roy, ihjel, jun3hong, Ashamed, Eisoncai, KYSXD, Kenoli