Staredit Network > Forums > SC1 Mapping Tools > Topic: Getting Starforge to work
Getting Starforge to work
Dec 5 2012, 12:10 am
By: Heinermann  

Dec 5 2012, 12:10 am Heinermann Post #1

SDE, BWAPI owner, hacker.

I wanted to test a new program I was writing but can't get Starforge to work.

If I download the one provided here, then I am stuck with the following:

I run SETUP1.EXE, I get the following error messages:
Code
---------------------------

---------------------------
Invalid command-line parameters.  Unable to continue.
---------------------------
OK  
---------------------------

Code
---------------------------

---------------------------
Setup was not completed successfully.
---------------------------
OK  
---------------------------

Code
---------------------------
Visual Basic 6.0 Setup Toolkit
---------------------------
Run-time error '5':

Invalid procedure call or argument
---------------------------
OK  
---------------------------


If I run StarForge.exe I get the following:
Code
---------------------------
SpritesLoad Debug
---------------------------
Failed to open stardat.mpq!
---------------------------
OK  
---------------------------

Code
---------------------------
DLL Debug
---------------------------
SpritesLoad failed!
---------------------------
OK  
---------------------------

Code
---------------------------
StarForge Error
---------------------------
There was an error loading sprites.

This is most likely because StarForge cannot find StarDat.mpq.

Please search for it yourself.
---------------------------
OK  
---------------------------


I locate StarDat.mpq and the following message appears:
Code
---------------------------
StarForge
---------------------------
Your registry settings have now been updated.  Please restart StarForge.
---------------------------
OK  
---------------------------


I click OK and do as it says. If I run StarForge.exe again, the same thing happens. It hasn't saved anything.

Now what?

EDIT: My InstallPath exists and is at the exact location that Starforge reads it from (HKLM).

I can also conclude that the exact path that Starforge is trying to load from matches the desired file.
[attach=9027]

Attachments:
Clipboard02.gif
Hits: 0 Size: 37.53kb

Post has been edited 2 time(s), last time on Dec 5 2012, 1:04 am by Heinermann.




Dec 5 2012, 1:59 am rockz Post #2

ᴄʜᴇᴇsᴇ ɪᴛ!

I can't even get comdlg32.ocx to register...

Do you need starforge or can you use ultimate?

Try putting starforge and starcraft in a folder that's not in program files.



"Parliamentary inquiry, Mr. Chairman - do we have to call the Gentleman a gentleman if he's not one?"

Dec 5 2012, 2:09 am jjf28 Post #3

Cartography Artisan

Quote
I can't even get comdlg32.ocx to register...

I think I just did that that last week... did you remember to run command prompt as administrator? My copy's attached.




As for starforge I had the same issues last time I tried to get it running - would say it was all good and to restart it, and then come up with the same errors.

Attachments:
Comdlg32.ocx
Hits: 1 Size: 194kb



Rs_yes-im4real - Clan Aura - jjf28.net84.net

Reached the top of StarCraft theory crafting 2:12 AM CST, August 2nd, 2014.

Dec 5 2012, 3:26 am rockz Post #4

ᴄʜᴇᴇsᴇ ɪᴛ!

ah that did the trick. and I pulled it up no problems. Didn't even look for my starcraft install (which isn't installed).



"Parliamentary inquiry, Mr. Chairman - do we have to call the Gentleman a gentleman if he's not one?"

Dec 5 2012, 4:01 pm Pr0nogo Post #5



I would strongly suggest disabling UAC (User Account Control) so you don't ever need to run things as administrator again.




Dec 5 2012, 7:50 pm Heinermann Post #6

SDE, BWAPI owner, hacker.

I have all of the above already.




Dec 16 2012, 4:19 am rockz Post #7

ᴄʜᴇᴇsᴇ ɪᴛ!

http://puu.sh/1Bq0c

Here's my copy of starforge.



"Parliamentary inquiry, Mr. Chairman - do we have to call the Gentleman a gentleman if he's not one?"

Dec 16 2012, 9:48 am jjf28 Post #8

Cartography Artisan

Quote
Here's my copy of starforge.
still no dice :(




Found some reading related to the setup error: VB6 Setup Toolkit

Allegedly there should be a setup.exe in addition to the setup1.exe? Also having these files installed may help "Files You Need to Distribute"

Also I can't locate any changes to the registry when it says it's updating it, perhaps some manual editing is in order... might do some-more testing tommorow



Rs_yes-im4real - Clan Aura - jjf28.net84.net

Reached the top of StarCraft theory crafting 2:12 AM CST, August 2nd, 2014.

Dec 16 2012, 11:09 pm Heinermann Post #9

SDE, BWAPI owner, hacker.

Yep same as before. That folder is much cleaner though.




Dec 17 2012, 11:59 am NudeRaider Post #10

We can't explain the universe, just describe it; and we don't know whether our theories are true, we just know they're not wrong. >Harald Lesch

I just extracted rockz' Starforge to a non protected folder on my PC at work and it worked without problems. I had a lot of errors because I don't have StarCraft on it, but it did start. It's a WIndows XP machine though.

However this shows that there's no need for installations of any sort. Just run it from the folder.




Feb 14 2015, 12:22 am jjf28 Post #11

Cartography Artisan

Could you possibly re-post your starforge version rockz? I tried the one in SENs database on windows 7, windows XP (on which some version of starforge had worked before) and a windows 2000 VM, all with lots of attempted tweaking to no avail... leading me to wonder whether http://www.staredit.net/sc1db/file/9/ legitimately worked for anyone :P

Post has been edited 1 time(s), last time on Feb 14 2015, 12:33 am by jjf28.



Rs_yes-im4real - Clan Aura - jjf28.net84.net

Reached the top of StarCraft theory crafting 2:12 AM CST, August 2nd, 2014.

Feb 16 2015, 3:10 pm rockz Post #12

ᴄʜᴇᴇsᴇ ɪᴛ!

bah puush fails me again.

Try this. Found it in my cloud:
http://url.cn/g06S8C
I've also got starforge ultimate which barely works.



"Parliamentary inquiry, Mr. Chairman - do we have to call the Gentleman a gentleman if he's not one?"

Options
  Back to forum
Please log in to reply to this topic or to report it.
Members in this topic: None.
[11:38 pm]
jjf28 -- well hey, maybe you can use the gateway's warping effect, and replace it with a nexus
[11:37 pm]
jjf28 -- cut their power partway through
[11:37 pm]
jjf28 -- maybe power dependent buildings you could
[11:36 pm]
jjf28 -- you can certainly make the building and play the sound, I don't think you're going to reliably be able to farm partially warped buildings tho
[11:34 pm]
martosss -- I've seen some crazy effects with EUD though :) like ... fireworks .. or rotating dying units that create a storm-like effect
[11:32 pm]
martosss -- you can play any sound ... but i dont think you can do the nexus thing .. i'm not sure if you can achieve that
[11:26 pm]
sraw531 -- at worst I would like a system in which you could do cool cinematic effects - a landing sequence in which the buildings actually warp in instead of being created and playing the sound of them finishing
[11:24 pm]
sraw531 -- I want you to be able to make a base with a corsair as a probe, basically, but without modding or euds at all.
[11:23 pm]
sraw531 -- timers are not the issue. its the building itself.
[11:23 pm]
martosss -- If you want a timer, why not just use death counters to achieve it? If you also include hyper triggers(which you most certainly should do for a good map) it would give you a very precise counter system
Please log in to shout.


Members Online: jjf28, Roy, martosss, Hilleres90, sraw531, KrayZee, ydykeja