Staredit Network > Forums > General StarCraft > Topic: Starcraft Bugs
Starcraft Bugs
Aug 25 2011, 6:33 am
By: DT_Battlekruser  

Aug 25 2011, 6:33 am DT_Battlekruser Post #1



I recently started playing a bit of Starcraft LAN games and such, and have been experiencing a surprising number of bugs. On my laptop (64-bit Seven) the color palette is scrambled somewhat on the loading screen and menu screens, and on both my laptop and older desktop (XP Pro) Starcraft seems to be crashing more than I remember. It seems to be segfaults mostly, and I got Seven to bluescreen for the first time after Starcraft crashed. Also, on my desktop as far as I can tell SC managed to take a dump all over some part of the OS and rendered it unbootable (seems like bad luck to me as to where the bad data went).

Was Starcraft always this buggy or is there something going on with my setup? It's been a while since I've played and I forget if the occasional crash or segfault is normal.




None.

Aug 25 2011, 8:41 am Lanthanide Post #2



Windows 7 colour fix from Blizzard: http://us.blizzard.com/support/article.xml?locale=en_US&articleId=36371&pageNumber=1&searchQuery=windows+7



None.

Aug 25 2011, 12:11 pm Apos Post #3

I order you to forgive yourself!

That's sick! It fixed my color problem.

@DT_Battlekruser: I've never experienced any bug like that other than the color bug. I have Windows 7 64-bit.




Aug 26 2011, 6:43 pm DT_Battlekruser Post #4



Thanks for the color registry fix - now I hopefully won't have to alt-tab to reset the palette when my screen decides to go nuts midgame.

While Starcraft was crashing on my desktop, it seems the unbootable OS *might* have been due to a very coincidentally timed failing IDE cable. I did a bit of hardware work and found it; with the hardware fixed Windows boots again.




None.

Aug 26 2011, 11:12 pm Dem0n Post #5

ᕕ( ᐛ )ᕗ

Ohh that's cool. Do you have to run that file every time you want to play starcraft, or does it permanently add it to your computer's registry? Also, I seem to have a problem when I play Starcraft in fullscreen. If I alt+tab out of it and then try to maximize it, the screen will be black for like 2 seconds and then it'll go back to my desktop. This always happens unless I start clicking my mouse a lot when the screen is black. If I do that, then Starcraft will actually maximize. Does anyone have this problem/know of a way to fix it?



Memes gather, and now my watch begins. It shall not end until my death. I shall take no wife, hold no lands, father no children. I shall wear no crowns and win no glory. I shall live and die at my post. I am the sword in the darkness. I am the memer on the walls. I am the shield that guards the realms of memes. I pledge my life and honor to the Meme's Watch, for this meme and all the memes to come.

Aug 26 2011, 11:32 pm iCCup.xboi209 Post #6



The .reg file happens permanently however if you like to undo the changes, you can make a backup of your registry.




Aug 26 2011, 11:39 pm Lanthanide Post #7



Never had that problem, Demon.

Note that the registry fix isn't 100%, I fairly often get the colours screwing up in battle.net, and sometimes in the main menu areas as well. Once or twice I've had the colours get corrupted while I was playing, but simply alt-tabbing out and in always fixes it. Sometimes you see a brief flash of corrupted colours and whatever the registry fix does, quickly clears colours back to what they should be.

They've also got a registry fix for D1 as well.



None.

Aug 27 2011, 7:29 pm DT_Battlekruser Post #8



Yeah, I was noticing that the colors are only slightly better with the fix. Oh well, it's still better than before.



None.

Aug 27 2011, 8:07 pm Ahli Post #9

I do stuff and thingies... Try widening and reducing the number of small nooks and crannies to correct the problem.

I would use Win98/ME compatibility mode and "ddemulate" command for additional help, too.




Aug 27 2011, 9:45 pm iCCup.xboi209 Post #10



I don't think compatibility mode helps at all. The "ddemulate" command helped with the icons and lat bars though :D
I made a guide on fixing the color issue, while most people say to kill explorer.exe, I do different things. Install MS updates, disable visual themes and desktop composition, disable Aero, etc




Options
  Back to forum
Please log in to reply to this topic or to report it.
Members in this topic: None.
[09:32 pm]
O)FaRTy1billion[MM] -- iirc the last byte in the TRIG is for more flags or something
[09:15 pm]
Wormer -- also, when I wear cartoon it turns off the dynamic lighting and doesn't turn it on when I switch back, maybe that kind of incompatibilities were the problem
[09:02 pm]
Suicidal Insanity -- Wormer
Wormer shouted: Pr0nogo THAT why it's impossible to switch that skin on the fly
My guess is GPU memory constraints
[09:02 pm]
Suicidal Insanity -- I think its 27 and padding
[09:01 pm]
Wormer -- Wormer
Wormer shouted: or the guide (http://www.starcraftai.com/wiki/CHK_Format#.22UNIT.22_-_Placed_Units) is wrong there and it should be u8[27] ?
the right link http://www.starcraftai.com/wiki/CHK_Format#.22TRIG.22_-_Triggers
[09:01 pm]
Wormer -- or the guide (http://www.starcraftai.com/wiki/CHK_Format#.22UNIT.22_-_Placed_Units) is wrong there and it should be u8[27] ?
[08:59 pm]
Wormer -- anybody knows why chk format has a list of 27 player group IDs (http://www.starcraftai.com/wiki/CHK_Format#List_of_Players.2FGroup_IDs), but TRIG section uses an array of 28 elements => suppose the last byte is padding as well?
[08:57 pm]
Wormer -- but it's actually possible to switch between cartoon and classic skin which is cool
[08:52 pm]
Wormer -- Pr0nogo
Pr0nogo shouted: they coded a new system in for it
THAT why it's impossible to switch that skin on the fly
[08:51 pm]
Pr0nogo -- i don't remember if it was because the old system was limited to only 2, or they didn't know how to increase it, or what
Please log in to shout.


Members Online: Roy, Pandut, DarkenedFantasies